Recent posts

Tutorials, Tips and How-Tos / Re: Pagination in Persian/Arab...
Last post by PatJr - May 18, 2023, 07:54:22 PM
it was clunky but I think it works
make a character style
edit the master page
apply the master page
go back and reedit the master page and use select all so the page variable gets selected
apply the page number style
end master page edit

not sure it worked because I'm not sure what it should look like??
I did have to do the double edit on the master page to get style to take on page variable

Tutorials, Tips and How-Tos / Pagination in Persian/Arabic
Last post by farzan - May 18, 2023, 06:21:30 PM
Dear All,
Is there any workaround to do the pagination in Persian/Arabic? When making page numbers in master page I chose a Persian/Arabic font. However it shows the page numbers in English. Is there a way to change the language so that Scribus understands the page numbers should be in Arabic/Persian?
Thank you.
Installation and Setup / Re: .sla file cannot be opened...
Last post by core - May 18, 2023, 11:15:42 AM
That fixed it.

many thanks
Scripts and Plugins / Re: Free lancer searched: Deep...
Last post by founder - May 18, 2023, 09:11:11 AM
Quote from: AdmFubar on May 17, 2023, 09:48:02 PMAre you trying to translate to a new layer? or do you want to translate a layer on the fly as needed?

One layer general, usual for pictures.
One layer for each language.
Translate the German or English layer to all the other languages.
Store the result in the layer for this language.
Scripts and Plugins / Re: Free lancer searched: Deep...
Last post by AdmFubar - May 17, 2023, 09:48:02 PM
Are you trying to translate to a new layer? or do you want to translate a layer on the fly as needed?
Installation and Setup / Re: .sla file cannot be opened...
Last post by AdmFubar - May 17, 2023, 08:45:33 PM
Two possibilities here, the file is damaged, or at one time you used a new version of Scribus to create.

Easiest solution: try the 1.5.8 version of Scribus and see if it opens. If you get the same error then the issue is a damaged file.
Installation and Setup / .sla file cannot be opened wit...
Last post by core - May 17, 2023, 06:15:08 PM
I just installed the lastest version (1.4.8) of Scribus in my Windows 10 computer.
I tried to open a file that was created a while back but I updated it last in Feb 2023.

I now cannot open it and I get an error saying:

This file may be damaged or may have been produced in a later versions of Scribus.

This is an odd error since I have the latest version of Scribus installed.
Funny but I recall this problem before and have searched the forum for a solution but have not been able to find it.

Can anyone suggest what I can do? any help would be greatly appreciated

(I got a screenshot of the error but don't know how to attach it to this post)

Scripts and Plugins / Free lancer searched: DeepL in...
Last post by founder - May 17, 2023, 02:55:55 PM
I search somebody with experience in the Phyton programming at Scribus.
I use since I use Scribus sevral layers like General, English, German.
So I have in the same document all language versions.
Select General and German for the German version.
Select General and English for the English version.

Now I want this with the API interface of

Rename text fields into text491 TextPageNNFieldNNde for example
Create layers for each language
Create text fields for each language
Call the DeepL API
Check the translated text field for overflow errors.
Generate PNG and PDF for each language, with files names generated by name giving policies.

When You know also OpenShout would be great.
The next task is to call the API of, a speech synthesizer
and create OpenShot video cutting files and create
full automatic, the PDF and the videos in many different languages.
Linux / Re: [Scribus 1.5.7] Cannot ge...
Last post by asdinnie - May 16, 2023, 09:27:41 AM
Hi Nermander & AdmFubar

Many thanks for your notes & feedback.

I too have some suspicions about the printer driver.
I'm going to look at it more fully when I do my next OS upgrade (will be a clean install).

The original printing problem could also be Scribus.  I now recall the last Laserjet printing issue I had was resolved by the following Scribus release.  I was most pleased when this happened!

I've been using Ocular for years with no problems.
I'll look around for another suitable KDE PDF viewer to see if it can bypass this problem in the meantime.

Linux / Re: [Scribus 1.5.7] Cannot ge...
Last post by AdmFubar - May 16, 2023, 12:51:06 AM
Quote from: asdinnie on May 15, 2023, 11:06:35 AMThanks RodneyLee

I have printed from PDF files before with Scribus.  See below.
PDF file printing doesn't work as well as native printing for what I am doing (newsletters, etc.).  There are less printer controls available. It's also easier to print individual pages, etc.

I am also having issues with getting duplex printing from Okular atm.  I am using Okular to handle PDF files as I am running a KDE desktop. All other apps seem to find the duplex option okay.  Okular shows that the printer supports duplex printing but doesn't  make the duplex options available (they are greyed out).   This makes the original printing problem described in my first post more of a pain.

BTW I did have some Scribus printing issues with the previous printer when I set it up, which could have been postscript-related?  I had to resort to printing to PDF files until it was resolved.
These issues were eventually solved by changing printing to PDF not postscript.  These issues were not found with the other apps I was printing from.  It was a Scribus-only issue.

I am wondering whether the printer is receiving a format or postscript command that it cannot accept/print.  Therefore the print job is cancelled without an error message.

Hope this is clear.

This could be an issue with your printer driver. I checked several versions of drivers available for my printer and noted that there are options missing or added depending on what driver is being used.  I've looked at the CUPS, MFG, Foomatic, and OpenPrinting and the MFG's. It might be that Okular is picking up a certain driver and there for showing only certain options being available.

Try another pdf viewer and see if that offer a solution