Recent Posts

Pages: 1 2 3 4 5 6 7 [8] 9 10
71
Layout Issues / Re: Baseline grid creates weird spaces
« Last post by Ewac on December 20, 2021, 11:55:53 am »
Thank you for the quick reply. The file is rather big, so I'm sending a copy with only those pages that contain the error (I'm not using the style with baseline grid on the other pages). I think I find two instances of the weird spacing and there is also an instance where a column break is made, even though there is still enough space to put two more lines (setting is set on not seperating first and last two lines).
72
Layout Issues / Re: Baseline grid creates weird spaces
« Last post by utnik on December 20, 2021, 11:09:46 am »
hi ewac

if there's no paragraph break in the left column, this is really weird. (you should show the control characters to be sure…)
could you share the .sla file for a deeper investigation?

utnik
73
Beginner Talk / Re: Image frame cross lines not appearing (not possible to "get image")
« Last post by Ronald on December 20, 2021, 10:51:45 am »
1.4.8 has the "collect for output" option.

I though I would be clever and separate the file into 2 files to avoid potential memory issues causing my troubles. When I saved my original file as a second version and deleted the initial images in this copy I would have assume my original file to stay in tact, however there also the images were removed even though the "save as" option was used.

I'm about to give up on this. I can't find the logic ins some issues, however computers don't make mistakes so the mistake must be in the person using it  :(. More than 2 months are gone now and still no result. Apparently this program is too sophisticated for me.
74
Layout Issues / Baseline grid creates weird spaces
« Last post by Ewac on December 20, 2021, 10:14:10 am »
Hi, I have a problem with the baseline grid, it creates weird spaces between lines in random places and I cannot find the reason or way to fix it. This is a text frame with two columns, all text in the same style that has baseline grid as setting for line spacing. I already checked and there are no additional breaks or anything that would create these spaces.
The screenshot shows an instance in the left column (the right column has a regular paragraph break).
75
PDF Generation / Re: File | Export | Save as PDF... - Causes crash SIG11
« Last post by utnik on December 19, 2021, 04:47:09 pm »
hi scribusribus

if you can reproduce the crash with another file, you should open a bug report. if it's just this single file, it's up to you. but that's the place where the developers might jump in…

utnik
76
if I were you I'd try the latest Scribus 1.5.7, you can have both installed without issue. (always use a backup file as 1.4.8 cannot load 1.5.7 files)
if 1.4.8 has "collect for output" which gathers all you project files in on place, you can then zip them up and post in this thread (if not to big)
77
Beginner Talk / Re: Image frame cross lines not appearing (not possible to "get image")
« Last post by Ronald on December 18, 2021, 06:19:57 pm »
Besides the issue of images not appearing I additionally have problems with importing Inkscape vector files. I made A4-size vector with additionally 3mm bleed all around. When importing that into the Scribus document which is also set to A4 with 3mm bleed all around the proportions of the vector get distorted even though the size is defined the same.
78
Beginner Talk / Re: Image frame cross lines not appearing (not possible to "get image")
« Last post by Ronald on December 18, 2021, 06:16:08 pm »
Thanks again RodneyLee for your kind reply. As said I'm a beginner so therefore I may not understand the approach of sending you the file. The sla file itself doesn't encompass the images, but incorporates links to the images. So if I send you the sla file without pictures and your computer for example has a bigger memory than still no cause is known. On your computer it may work and on mine it may not. I suppose the image quality when opening Scribus may have some influence since opening the file takes quite some time. But the option to make the resolution lower whilst working in Scribus (merely the preview) I can't find.

All in all the "beginner" status is killing me on this project. I clearly underestimated the troubles I would run into.
79
PDF Generation / Re: File | Export | Save as PDF... - Causes crash SIG11
« Last post by ScribusRibus on December 18, 2021, 04:33:41 pm »
If you have access to another Linux installation and distro, you might check if Scribus will run without problems on that system.

You might check your current Linux installation for bugs.

I would be inclined to agree - except all other aspects of Scrubus, along with all other applications etc, work fine in both cases.

Quote
You might re-install Linux, GhostScript and Scribus (This is what I would consider first).

I would be inclined to agree, if I had any issues with Ghostscript or Scribus - except all other aspects of Ghostscript & Scribus work fine in both cases (remember the printing to .ps above, that was Scribus sending to Ghostscript. So successfully that the very same .ps file was used to import back into Scribus to enable me to save to PDF without crashing. So the options for where the fault exists are reducing fast...)

Quote
You might search for the string »signal 11« in the Search function in this forum — there are several hits, and maybe they can point you into the right direction.

I have done this, and I have not been able to find anything remotely like this issue so far.

Quote
For friends, I have installed and configured Scribus on Ubuntu and Debian systems and never experienced any issues.

Indeed, one system is Ubuntu based (Linux Mint), the other is Arch based (Manjaro) - neither are demonstrating issues with Scribus per se, except for this one file I have created with Scribus... the culprit here appears to be Scribus - whether anyone likes that or not is somewhat irrelevant and utterly unhelpful to boot.

Quote
Other than that, I don't have any ideas.

...and I wholeheartedly appreciate your feedback, but I am convinced it is a Scribus issue, more specifically, I believe it is a structure issue with the file itself, or how something about the file is NOT being handled properly by Scribus.

Narrowing down the cause of this issue is the challenge here, of which I am now a little closer!

I decided to make a copy (Save As...) of the original file - which still demonstrates the exact same behaviour, ie attempting to save to PDF causes Scribus to crash - and selectively delete content from it until I could successfully save to PDF.

Well now, when I deleted the content of the first text box, saved the file, then attempted to print to PDF - Scribus did NOT crash!

I then restored the content and went through it character by character (in Scribus) looking for oddities... there was one, where the font type changed at the end of the line.

I proceeded to remove all formatting and style from the text, but it made no difference. I even went through the process of deleting a character, saving the document, attempting to save as PDF, enduring the crash, restarting Scribus to delete another character, save, print, crash, repeat... until I no longer crashed when attempting to save to PDF.

This took a while, and I only succeeded to save to PDF when all text in the text box was removed.

The pre-flight check flagged 1 issue, and empty text box (surprise, surprise!) and I was able to save to PDF.

I then removed the text box, saved the file, and once again Scribus would crash instantly when attempting to save to PDF - as far as I can establish, this is definitely a Scribus issue, probably a file structure issue, or  an error handling issue - or both.

Putting the text box back - a new one - allowed me to get to the pre-flight check okay, but as soon as I hit "Ignore errors" Boom! Scribus crashes.

So whilst I wholeheartedly appreciate all the feedback and the suggestions from you guys, I am less concerned with the issue being with the installation of Linux and the supporting applications, including Scribus, and more so with the function (or lack thereof) of Scribus when attempting to save to PDF.

If someone can tell me specifically what I can do with the installation of two machines - that for all other purposes including Scribus work just fine - that will fix this issue, then the problem certainly resides with Scribus for the time being.

Perhaps there is a better place for me to highlight this issue where a developer might have deeper insight into how Scribus is possibly failing - or whether indeed I am failing somehow!

Thanks.
80
would you send me your file instead and I'll grab 1.4.8 and test it, either that or you might grab 1.5.8 just remember to use a backup file
Pages: 1 2 3 4 5 6 7 [8] 9 10
palmate