Author Topic: MonthlyCalendar Tkinter error in ubuntu  (Read 1361 times)

srikrishnan

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
MonthlyCalendar Tkinter error in ubuntu
« on: December 12, 2019, 03:46:55 am »
Hi All,

I am trying MonthlyCalendar.py

which I got from the below scribus forum thread "http://forums.scribus.net/index.php?topic=3495.0"

In this "MonthlyCalendar_v2.zip" has been released for Linux also,

I have tested it in Windows 7 it works well. but not in Ubuntu. when I run, it says that "This script requires Python 2 Tkinter properly installed"

when I tried it in my terminal, it says everything which needs for running this script has been installed.

srikrishnan@srikrishnan-desktop:~$ python
Python 2.7.17rc1 (default, Oct 10 2019, 10:26:01)
[GCC 9.2.1 20191008] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>
Below command also popup Tk dialog box
>>> Tkinter.Tk()
<Tkinter.Tk instance at 0x7f2139849eb0>

can anybody help me to solve this problem? what goes wrong with installation of "Python 2 Tkinter"?

regards,
Srikrishnan



a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2472
  • Karma: 36
    • the graphics lab
Re: MonthlyCalendar Tkinter error in ubuntu
« Reply #1 on: December 12, 2019, 09:25:00 am »
this message comes from the script and is misleading.

depending on your scribus version you will need "Python 3 Tkinter".

so, which version of scribus do you have on ubuntu? if it's the trunk ppa, you will need to install the python 3 tkinter (by default, i guess that the python command in the terminal will give you python 2).

on windows scribus is using (by default) its own python and tkinter so you won't need any further tweaking (but will have a harder time, when you want to use local python packages with scribus...)

srikrishnan

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
Re: MonthlyCalendar Tkinter error in ubuntu
« Reply #2 on: December 12, 2019, 12:11:21 pm »
Hi a.l.e,

Thanks for your reply

I am having

Scribus Version 1.5.6.svn
06 November 2019
Build ID: C--T-F-C1.16.0-64bit
Using Ghostscript version 9.27

can you please direct me how to tweak this?

regards,
Srikrishnan

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2472
  • Karma: 36
    • the graphics lab
Re: MonthlyCalendar Tkinter error in ubuntu
« Reply #3 on: October 27, 2020, 10:55:16 am »
at that time i did not have a tkinter installed for python3 and could not do further tries...

but since this thread still shows up in the search results for scribus and tkinter here some fresh news:

- scribus 1.5.6svn uses python 3 not python 2. you need a version of the script that is ported to python 3.
- scribus does not use the default python version from your system. you can use the output of
  import sys
  print(sys.version)
  to know which version scribus is using and you can then make sure that the version of python-tk that is installed on your system does work with it.