Author Topic: Import odt file with style through API.  (Read 2302 times)

baudouin

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Import odt file with style through API.
« on: April 30, 2012, 09:22:51 am »
When in Scribus, it is easy to import an odt file with its styles ,but looking for a way to do this with API I could not find any solution. One can add text or import an image but nothing about text or am I not looking at the right place.
Thanks a lot for any information about that.

xtofa

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Import odt file with style through API.
« Reply #1 on: June 06, 2012, 01:06:16 pm »
I had the same problem and filled a bug report (feature request).

I was told that this shouldn't be hard to implement... Unfortunately, nothing happen since then...  :(

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1920
  • Karma: 26
    • the graphics lab
Re: Import odt file with style through API.
« Reply #2 on: June 06, 2012, 07:20:02 pm »
basically: somebody who is able to write script, with some fantasy and a little bit of help from more experienced people, should be able to add a command to the API...

if the command is that important to you, you could consider contributing its implementation...

the following post (and its followups)

http://www.graphicslab.org/Blog/Enhancing-the-Scribus-Scripter

can be helpful to understand, how to add a new command.

ciao
a.l.e

baudouin

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: Import odt file with style through API.
« Reply #3 on: June 25, 2012, 12:33:48 pm »
Of course I would be glad to contribute but the url given is of no use. Error 404.

url misspelled or too old.

Any other help would be appreciated.

http://www.graphicslab.org/Blog/Enhancing-the-Scribus-Scripter

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1920
  • Karma: 26
    • the graphics lab
Re: Import odt file with style through API.
« Reply #4 on: June 25, 2012, 01:12:05 pm »
ooops... i've redone the website this night...

... and missed those kind of links...

i setup a redirect this evening...

for now you can go to

http://graphicslab.org/blog/?page=5

... sadly, i just notice right now, that now that the single post view does not work, either...
some more work for this evening...

but, at least, you got a nice 404 error...

so sorry
a.l.e

p.s.: i fixed the old url schema and the Blog/ addresses show again the old articles!
« Last Edit: June 26, 2012, 07:41:53 am by a.l.e »