Text / Image Frames and Shapes look 'liquid'.

Previous topic - Next topic


Hello everyone,

I work with Scribus 1.5.7 on Linux Mint 20.1 Cinnamon;

unfortunately I have this type of inconvenience:  :(
when I create a text frame the frame does not follow the mouse cursor as it should be, it does so with a lot of delay and this involves a considerable waste of time and precision;
even if I want to make a change to the width / height the movements take place with a considerable delay so as to make the frame seem 'liquid'.
Of course, this also happens with the Picture Frame and with the various shapes.

If I can't fix it I'll have to give up using Scribus, if anyone has a tip to solve it's welcome ... Thank you very much... :)


I just tested here, Mint 20.xx no problem what so ever, try turning off your grid, is your System ram low?


I also just tested on Mint 20.1 and had no problems also. That problem looks to be ram or video card problem to me.




@RodneyLee and @mnawij

Thanks for your interest and for the answers,
you too with Mint 20.1 Cinnamon?

I have a desktop pc with 8GB of RAM and I don't have any other malfunctions with other software;
I work a lot with Inkscape and Gimp, even when I keep them open at the same time with Firefox I have never encountered any slowdowns or malfunctions.

Only with Scribus it happens to me with or without a grid, I tried to uninstall and reinstall but, nothing changes.
Do you think 8GB of ram is few? Even to make a single text frame?

Thanks for your time, I appreciate it very much ...



I understand where the problem lies:

I have always used the Wacom tablet, I do a lot of graphics and photo editing and I am so used to it that I use it for everything, I have always closed the mouse in my drawer, I never use it.

I do not do it long, took, inserted and 'miracle' Scribus is back to work normally.
The strange thing is that with the other versions of Scribus I have never had any kind of problem, evidently the latest versions do not adequately support the tablet.

Well, I'm glad I solved it, I was already looking around to see how to replace Scribus, which is anything but simple, it means that when I need it I will use the mouse.

Thanks to those who have read and answered me, I also put SOLVED in the title for others who may have the same problem as me.

Thanks a lot to everyone... :D



Digging old thread, but I am having exactly same problem with Wacom (and other tablets). Using mouse everything works fine.  How did you resolved it?


This is happening with few more Qt based apps.
Workaround I found is to, before starting Scribus, do 'xinput float deviceID'. Start Scribus. After Scribus opened, do "xinput reattach deviceID".
I do not have knowledge to figure out why is this happening with some Qt apps and graphic tablets. Neither I know where should I report this ...