Render Frame path, OS 10.11 el Capitan

Previous topic - Next topic


Scribus 1.4.5, OS 10.11 - Also attempted with Scribus 1.5.0

If anyone has been able to find a path (Preferences > External Tools > Configurations) LaTeX which works without disabling SIP (System Integrity Protection), posting it here would be greatly appreciated. I've tried entering all the suggested paths into the External Editor box without success.

Selecting the "Render Frame" tool and drawing one on a new page returns "Render Error" in the box, and the error message: The application "pdflatex --interaction nonstopmode" failed to start! Please check the path: " i.e., no path is shown.



I actually fixed this and I don't remember how I did it  :-[
I may have used homebrew (the MacOSX package manager). I'll see if I can remember.


Check out
It's the way you can use the latest bleeding edge Scribus version.
It's considered unstable so backup any work you do in it before you use it.

I use it as my go to default version of Scribus. FYI There are also people on the Mailing List that have successfully printed projects through a professional printer using 1.5.1svn


My Scribus (both 1.4 & 1.5) was installed from a .dmg on SourceForge. I tried HomeBrew briefly after problems with Fink, but now am firmly in the MacPorts camp. I used to have the MacPorts Scribus (currently offering the 1.4.5 version), and recall being able to use render frames. However, that was before SIP. Maybe I need to try installing it from MacPorts again.

Thanks for the responses.

Installing 1.4.5 from MacPorts left me with the same defaults and same results. Back to square one. The Preference file (scribes 140.rc) shows [LatexEditor="/Library/TeX/texbin/LaTeX"] which apparently takes me to the appropriate directory, since adding "pdflatex --interaction nonstop mode" fires up

kpathsea: Running mktexfmt LaTeX.fmt
mktexfmt: mktexfmt is using the following fmtutil.cnf files (in precedence order):
mktexfmt:   /usr/local/texlive/2015/texmf-dist/web2c/fmtutil.cnf
mktexfmt: mktexfmt is using the following fmtutil.cnf file for writing changes:
mktexfmt:   /Users/ssanders/Library/texlive/2015/texmf-config/web2c/fmtutil.cnf
mktexfmt [INFO]: Disabled formats: 10
mktexfmt [INFO]: Not selected formats: 46
I can't find the format file `LaTeX.fmt'!

which may be a clue?


Do you mind reporting this in a ticket on ? Thanks!