Author Topic: Question re opening PostScript files  (Read 2077 times)

tduell

  • Newbie
  • *
  • Posts: 38
  • Karma: 0
  • Scribus User
Question re opening PostScript files
« on: October 25, 2013, 03:15:44 am »
Trying to learn how to use Scribus, I have been looking at how to import PostScript, as per <http://documentation.scribus.net/index.php/Importing_Vectors> which says...

"A recommended way to import EPS/PS files in to Scribus is to simply create a new document via File > Open. Select EPS/PS from the dropdown under File Type in the file dialog. Then directly import the EPS/PS file. This creates a new document in which the page size is automatically calculated from the EPS bounding box. A bounding box in an EPS file is a rectangle that describes the actual size of the graphical content."

I tried an example found here <http://lbproject.sourceforge.net/examples.html>, the first (top) PostScript example which is "generic_en_linux_brochure_watermarked.ps.gz".

Attempting to open the extracted ps file in Scribus results in a bit of a mess, and looks as though the two pages are overlaid.
I then tried by splitting the 2 page PS into two files, each one page, and then opening one of the single page PS files in a new Scribus doc. For each of these 1 page PS files the result is unsatisfactory, with the top part of the file content appearing to be cut off.
The original 2 page PS file and each of the 1 page PS files are rendered OK by the document viewer here in Fedora 19.
I have had the same result using 1.4.3 from the Fedora repo and from a build of the current development source.
Is this expected behaviour; am I tackling this incorrectly, or is there a problem with Scribus?

Cheers,
Terry

tduell

  • Newbie
  • *
  • Posts: 38
  • Karma: 0
  • Scribus User
Re: Question re opening PostScript files
« Reply #1 on: October 26, 2013, 01:39:22 am »
I can now report that this one is "solved" as well!
I have just rebuilt from the current development source, and this time I noticed that the cmake process hadn't found a couple of devel libs (poppler and PoDoFo). I must have missed those messages last time.
A build with those devel libs now loads the PS files and renders them as expected.
Not sure why v1.4.3 from Fedora repo didn't handle the test PS files.

Cheers,
Terry