Fill image frame script works on 1.5svn but not 1.4.2

Previous topic - Next topic



I have tried all the fill image frame scripts posted on on 1.4.2 and none of them worked with more than one image, so then I modified one of them a bit, but still with no result. then, I tried the modified one in 1.5 SVN and it worked. I have tried it on 3 1.4.x version with no success: the official one from the Ubuntu repo: 1.4.0, the latest stable 1.4.2, and currently on 1.4.3 SVN.

The following works only for a single image in 1.4.x and for as many as selected in 1.5. Any idea how to make it work for multiple ones in 1.4.x?

from scribus import *
import os

objList = []

for i in range(selectionCount()):

for obj in objList:
    #setScaleImageToFrame(confined to frame = bool, proportional = bool, name)
    setScaleImageToFrame(True, False, obj)
    scaleX, scaleY = getImageScale(obj)
    setScaleImageToFrame(False, True, obj)
    if scaleX > scaleY:
        scale = scaleX
        setImageScale(scale, scale, obj)
    elif scaleY > scaleX:
        scale = scaleY
        setImageScale(scale, scale, obj)


try moving the act of "selecting" a single object inside the "for" cycle.
I've experienced some similar issue, and found that in many cases operating on the currently selected object works, while the corresponding command using the name of the object does not.