Pages scroll too quickly with Mac touchpad

Previous topic - Next topic

dbe4876

I installed Scribus to my iMac. I find that when I scroll vertically using my touchpad the scrolling is much too quick and its hard to control page scrolling. This is NOT happening in other applications on my iMac (like this form page in Firefox scrolls just fine). Thoughts? Suggestions? Is there any application tweaking I can do? Thanks

toyotadesigner

Same problem for decades over here. Seems macOS accelerates the cursor more than other operating systems.

Workaround: Use the arrow keys.

AdmFubar

#2
There might be an option. In Preferences/User Interface/Interactivity  tab, there is an option for  wheel jump, it would be worth a shot  to try adjusting that.
Using Scribus 1.5.8 + 1.6.1, openSUSE 15.5
Advanced hobbyist

toyotadesigner

Wow!

Thanks a ton @AdmFubar for this tip, it works like a charm...

I always looked for »mouse speed«, but »wheel jump« didn't mean anything to me. Maybe the developers should change the option to »mouse wheel speed« — this would be more to the point.

AdmFubar

#4
prolly a carry over term before touch pads were in use.
Using Scribus 1.5.8 + 1.6.1, openSUSE 15.5
Advanced hobbyist

toyotadesigner

Well, I don't have a Touch Pad, just the Mac Magic Mouse and an Intuos graphic tablet.

Is there any specific reason why this term can not be modified to a more logical meaning?

AdmFubar

#6
Developers would have to make the change. submitting a 'bug' report would get things rolling
Using Scribus 1.5.8 + 1.6.1, openSUSE 15.5
Advanced hobbyist

dbe4876

#7
Quote from: AdmFubar on June 24, 2022, 11:03:26 PM
There might be an option. In Preferences/User Interface/Interactivity  tab, there is an option for  wheel jump, it would be worth a shot  to try adjusting that.

Yea, that makes a helpful difference. More functionality would be better. Something that says "Scrolling speed" perhaps :) Thanks so much!

toyotadesigner

OK, I've submitted a bug report to change the name to »Scroll Speed«