Author Topic: Image frame cross lines not appearing (not possible to "get image")  (Read 926 times)

Ronald

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
  • Scribus User
I'm an absolute Scribus beginner. I've been using the program now for about two months. I have the issue that the cross lines in the "image frame" are not appearing. Perhaps I accidentally changed some settings without realising it? How come the cross in the "image frame" is not showing and could that relate to my issue of images not appearing when using the "get image"function?

I de-installed the stable version of Scribus 1.4.8 I use in Windows and re-installed 1.4.8 it once more to check if the program was corrupted by any chance. Unfortunately that doesn't resolve the issue for the cross lines in the image frame not appearing.

I am racing against the clock to get a photobook ready to give a friend as a present, unfortunately this issue is causing me not to be able to incorporate images.

Thanks in advance for any reply, Ronald.

RodneyLee

  • Sr. Member
  • ****
  • Posts: 283
  • Karma: 3
  • Scribus User
Re: Image frame cross lines not appearing (not possible to "get image")
« Reply #1 on: December 12, 2021, 03:42:02 pm »
have you tried "Fit image to frame" if the cross lines are not showing up, maybe the image is loaded into the frame, just too big to see?

Ronald

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
  • Scribus User
Re: Image frame cross lines not appearing (not possible to "get image")
« Reply #2 on: December 12, 2021, 05:51:58 pm »
Thanks RodneyLee for your reply. All clues are highly appreciated since I'm really running out of time. The crosshairs in the image frames initially appeared. After adding a certain number of images to the project the crosshairs stopped appearing, however as you suggested I could still "fit" the images to the frame. Currently after using the "get image" command it doesn't even actually get the image so I can't adjust the the image to the frame or the other way around.

Could this be related to the specification of my computer? Insufficient memory or such items? Currently the document is 70 pages with about 150 photo's.

Ronald

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
  • Scribus User
Re: Image frame cross lines not appearing (not possible to "get image")
« Reply #3 on: December 12, 2021, 07:35:08 pm »
Very odd but when resizing the images that don't load to 60% it works. That would draw the conclusion that it's a memory issue of my computer, however the images that do load without issues can be added again so that would contradict the memory issue. Is anybody here familiar with making a book with a significant amount of pictures and running into the same / similar issue? Resizing pictures can't be the way to go otherwise there's little sense in creating a photobook.

RodneyLee

  • Sr. Member
  • ****
  • Posts: 283
  • Karma: 3
  • Scribus User
Re: Image frame cross lines not appearing (not possible to "get image")
« Reply #4 on: December 13, 2021, 04:45:31 pm »
can you turn down the quality of the images, as it's really just a maker to the real image (relative path) (image-preview setting) and see if the images load, also make sure show images is on :)

Ronald

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
  • Scribus User
Re: Image frame cross lines not appearing (not possible to "get image")
« Reply #5 on: December 13, 2021, 06:06:08 pm »
can you turn down the quality of the images, as it's really just a maker to the real image (relative path) (image-preview setting) and see if the images load, also make sure show images is on :)

Again thanks a lot RodneyLee. If I turn down the quality of the images (have to find out how to do that) that doesn't affect the quality when I export the file as a PDF to the printer, right? It only adjusts the quality in the ".sla" whilst viewing? Where do I find the "show image" option you are referring to?

Ronald

RodneyLee

  • Sr. Member
  • ****
  • Posts: 283
  • Karma: 3
  • Scribus User
Re: Image frame cross lines not appearing (not possible to "get image")
« Reply #6 on: December 14, 2021, 04:17:09 pm »
correct, its under ITEM/IMAGE/PREVIEW SETTINGS

Ronald

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
  • Scribus User
Re: Image frame cross lines not appearing (not possible to "get image")
« Reply #7 on: December 17, 2021, 05:38:17 pm »
Thanks again for the response. My version 1.4.8 doesn't provide the option mentioned. Under the "item" menu I have the "update image" and "image effects", not the option as you state. Perhaps because I use the "stable version" instead of the latest one?

RodneyLee, perhaps a rather forward question, but would you be willing to spend let's say 30 minutes to have a look at my screen online to see what I'm doing wrong? I'm located in the CET Timezone (GMT + 1 hour).

RodneyLee

  • Sr. Member
  • ****
  • Posts: 283
  • Karma: 3
  • Scribus User
Re: Image frame cross lines not appearing (not possible to "get image")
« Reply #8 on: December 18, 2021, 03:25:36 pm »
would you send me your file instead and I'll grab 1.4.8 and test it, either that or you might grab 1.5.8 just remember to use a backup file

Ronald

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
  • Scribus User
Re: Image frame cross lines not appearing (not possible to "get image")
« Reply #9 on: December 18, 2021, 06:16:08 pm »
Thanks again RodneyLee for your kind reply. As said I'm a beginner so therefore I may not understand the approach of sending you the file. The sla file itself doesn't encompass the images, but incorporates links to the images. So if I send you the sla file without pictures and your computer for example has a bigger memory than still no cause is known. On your computer it may work and on mine it may not. I suppose the image quality when opening Scribus may have some influence since opening the file takes quite some time. But the option to make the resolution lower whilst working in Scribus (merely the preview) I can't find.

All in all the "beginner" status is killing me on this project. I clearly underestimated the troubles I would run into.

Ronald

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
  • Scribus User
Re: Image frame cross lines not appearing (not possible to "get image")
« Reply #10 on: December 18, 2021, 06:19:57 pm »
Besides the issue of images not appearing I additionally have problems with importing Inkscape vector files. I made A4-size vector with additionally 3mm bleed all around. When importing that into the Scribus document which is also set to A4 with 3mm bleed all around the proportions of the vector get distorted even though the size is defined the same.

RodneyLee

  • Sr. Member
  • ****
  • Posts: 283
  • Karma: 3
  • Scribus User
Re: Image frame cross lines not appearing (not possible to "get image")
« Reply #11 on: December 19, 2021, 03:29:21 pm »
if I were you I'd try the latest Scribus 1.5.7, you can have both installed without issue. (always use a backup file as 1.4.8 cannot load 1.5.7 files)
if 1.4.8 has "collect for output" which gathers all you project files in on place, you can then zip them up and post in this thread (if not to big)

Ronald

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
  • Scribus User
Re: Image frame cross lines not appearing (not possible to "get image")
« Reply #12 on: December 20, 2021, 10:51:45 am »
1.4.8 has the "collect for output" option.

I though I would be clever and separate the file into 2 files to avoid potential memory issues causing my troubles. When I saved my original file as a second version and deleted the initial images in this copy I would have assume my original file to stay in tact, however there also the images were removed even though the "save as" option was used.

I'm about to give up on this. I can't find the logic ins some issues, however computers don't make mistakes so the mistake must be in the person using it  :(. More than 2 months are gone now and still no result. Apparently this program is too sophisticated for me.
« Last Edit: December 20, 2021, 11:10:12 am by Ronald »

Ronald

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
  • Scribus User
Re: Image frame cross lines not appearing (not possible to "get image")
« Reply #13 on: December 20, 2021, 12:07:00 pm »
The logic is fully beyond me, but when reopening the original file the images are there again. That means I got some courage to give it another try and see if splitting the file in 2 is an option.

RodneyLee

  • Sr. Member
  • ****
  • Posts: 283
  • Karma: 3
  • Scribus User
Re: Image frame cross lines not appearing (not possible to "get image")
« Reply #14 on: December 20, 2021, 04:59:57 pm »
if it's a memory issue that will help

 

palmate