Author Topic: Blend modes not displaying correctly  (Read 448 times)

Kurbitur

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Blend modes not displaying correctly
« on: October 21, 2020, 09:49:27 pm »
Hello,

I have been working on creating a album cover using Scribus and in one section there I have black text above a light blue image with the blend mode on the text set to overlay. In Scribus this turns the color of the text into a light blueish hue in sync with the image. However I sent the exported pdf to the printing company and got a reply back that the text is just pure cyan and doesn't look anything like I intended. After some googling I read that blending modes react differently to CMYK colorspaces over RGB colorspaces. So I guess my question is what am I doing wrong? Or are blendmodes in Scribus still a work in progress? Or do I need to change the colorspace of my file somehow?

Here are some images of what is going wrong
How I wanted it

How the printer see's it


Also if this is not in the right place on this forum feel free to move it.
« Last Edit: October 21, 2020, 09:53:08 pm by Kurbitur »

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2472
  • Karma: 36
    • the graphics lab
Re: Blend modes not displaying correctly
« Reply #1 on: October 22, 2020, 10:23:12 am »
hi kurbitur

does the pdf look good?
are the colors in the pdf rgb or pdf?
are the colors in the .sla file rgb or pdf?
have you enabled the color mananagement?
to which pdf version are you exporting your project?
which pdf version is the print shop expecting?
do they correctly support transparencies? (normally, i don't think that the transparencies are involved in the blending modes... but i'm not 100% sure of it...)

lot of questions... they might seem trivial to you... or already be too much... hard to say...

Kurbitur

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Re: Blend modes not displaying correctly
« Reply #2 on: October 22, 2020, 06:27:50 pm »
does the pdf look good?
That actually depends on the pdf viewer. In Okular it displays just like in Scribus and looks fine but when I open it in acrobat (which the printer is probably using) it looks not so good.

are the colors in the pdf rgb or pdf?
All the images are in CMYK and the pdf is exported for print so it should all be CMYK

are the colors in the .sla file rgb or pdf?
All colors are CMYK

have you enabled the color mananagement?
I tried enabling something there but didn't really understand it so I'm not so sure.

to which pdf version are you exporting your project?
I tried exporting in all version Scribus allows and the text was either completely black and ignoring the blend modes or it was exporting it weirdly

which pdf version is the print shop expecting?
They didn't specify anything but as I tried all versions Scribus allows it doesn't seem to matter at this point.

do they correctly support transparencies? (normally, i don't think that the transparencies are involved in the blending modes... but i'm not 100% sure of it...)
I noticed pdf 1.3 and some of the pdf x versions didn't support the blend modes/transparancies.

I got my brother to recreate this in InDesign to see if it was something with how blend modes behave and when he put a black text on top of the image and applied overlay blend mode the text turned white instead of dark blue like in Scribus so it might be that the blend mode in Scribus is working on some different math or something.

InDesign reference


jghali

  • Scribus Team Member
  • Administrator
  • Newbie
  • *****
  • Posts: 34
  • Karma: 1
Re: Blend modes not displaying correctly
« Reply #3 on: October 22, 2020, 06:42:12 pm »
>> (normally, i don't think that the transparencies are involved in the blending modes... but i'm not 100% sure of it...)

That's not correct, transparencies are involved in blending modes calculations.

jghali

  • Scribus Team Member
  • Administrator
  • Newbie
  • *****
  • Posts: 34
  • Karma: 1
Re: Blend modes not displaying correctly
« Reply #4 on: October 22, 2020, 07:20:07 pm »
>> I got my brother to recreate this in InDesign to see if it was something with how blend modes behave and when he put a black text on top of the image and applied overlay blend mode the text turned white instead of dark blue like in Scribus

Well the Indesign preview is in this case wrong due to Indesign display defaults. You have to turn overprint preview on and you will see that display will change. If you export to PDF, you will also see that text is not rendered white.

There might be also some confusion due to slight differences of translation. For eg overlay blend mode is translated in French to "superposer" in Scribus while it is called "Incrustation" in my version of Indesign. Same for screen blend mode : it is translated in French to "Ecran" in Scribus while it is called "Superposition" in Indesign.

jghali

  • Scribus Team Member
  • Administrator
  • Newbie
  • *****
  • Posts: 34
  • Karma: 1
Re: Blend modes not displaying correctly
« Reply #5 on: October 22, 2020, 07:21:47 pm »
>> After some googling I read that blending modes react differently to CMYK colorspaces over RGB colorspaces.

Yes, they will behave quite differently. So it is generally not a good idea to use RGB colors + blend modes in a layout targetted for printing on a professional press.

Kurbitur

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Re: Blend modes not displaying correctly
« Reply #6 on: October 22, 2020, 07:41:25 pm »
Quote
Yes, they will behave quite differently. So it is generally not a good idea to use RGB colors + blend modes in a layout targetted for printing on a professional press.
But in my case I was using cool black (CMYK) on top of a CMYK image or is there some colorspace setting or something I am missing out on? Also is there a overprint preview in Scribus?

jghali

  • Scribus Team Member
  • Administrator
  • Newbie
  • *****
  • Posts: 34
  • Karma: 1
Re: Blend modes not displaying correctly
« Reply #7 on: October 22, 2020, 07:49:00 pm »
Scribus performs all blending mode computations in RGB colorspace (like Indesign does by default). Scribus currently does not have anything like overprint preview. On Linux you can get it by using Adobe Reader (if you still can!), it is not enabled by default either for performance reasons, you would need to enable it manually in display preferences.

jghali

  • Scribus Team Member
  • Administrator
  • Newbie
  • *****
  • Posts: 34
  • Karma: 1
Re: Blend modes not displaying correctly
« Reply #8 on: October 22, 2020, 07:53:15 pm »
Forgot one thing, display of CMYK colors by Adobe Reader on Linux was pretty broken as far as I remember. This was apparently due to lack of color management. So not sure that Adobe Reader overprint preview will even provide an accurate preview on Linux.

jghali

  • Scribus Team Member
  • Administrator
  • Newbie
  • *****
  • Posts: 34
  • Karma: 1
Re: Blend modes not displaying correctly
« Reply #9 on: October 22, 2020, 07:56:41 pm »
Looking at the screenshots you posted in your first post, it is also possible that your printer's workflow has simply removed transparency informations (including blend modes) from your PDF. Lots of printer do not like transparencies either because of outdated RIPs or because they don't know how to handle them. Transparency and blend mode rendering in PDF is somewhat complicated stuff.

Kurbitur

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Re: Blend modes not displaying correctly
« Reply #10 on: October 22, 2020, 08:05:15 pm »
Scribus performs all blending mode computations in RGB colorspace (like Indesign does by default). Scribus currently does not have anything like overprint preview. On Linux you can get it by using Adobe Reader (if you still can!), it is not enabled by default either for performance reasons, you would need to enable it manually in display preferences.
Good to know! After reading through this https://graphicdesign.stackexchange.com/questions/31183/is-cmyk-mode-not-ideal-for-designs-with-blending-mode thread I think everything now makes sense. According to the replies there it seems that blending modes in CMYK don't really work/make sense and the fact that Scribus does all the computation in RGB colorspace makes the result I was getting logical.
I ended up solving this issue by just exporting an image of my design and then importing that image into my document again so I got the desired effect I wanted. Not ideal but it works.