Weird font rendering with mupdf

Previous topic - Next topic



I'm using Scribus for the first time and the fonts in my documents do not render properly once exported in pdf when using mupdf-based readers. Everything looks fine with Evince, but I would like to fix the problem, and also to make sure that everything will be fine if I print the document. Enclosed is a test example: there is some kind of aliasing effect, and also some parts of the letters appear in cyan rather than black. The problem is the same for all "zoom" levels.
This is a test document with one line in "Arial" and one in "Lato". I tried both embedding and vectorizing, same result.

Any suggestions?
[edit] Running Scribus 1.4.7 on archlinux.

[attachment deleted by admin]


I think I narrowed the problem: this only happens when choosing "printer" output in the Color tab of the PDF export window. Could it be a problem related to color profiles? I'm not really familiar with all that, not sure what could be the cause, but I guess this should help to understand the nature of the problem.
[edit] and also, it happens when exporting with compatibility for PDF 1.4 or 1.5. Looks like there is no problem for PDF 1.3.

Do you think that even with this rendering issue on the screen, there is a chance that fonts will be correctly printed? (Well, I don't have a printer here I cannot try.)

(Also, I updated both Scibus and mupdf, doesn't help.)