Acrobat Reader and *.ly links not working

Previous topic - Next topic

groovy Kimo

Hi all

Here's a strange problem:
Links with a .ly domain do not work in my Acrobat Reader (DC 2015.006.30173), but do in Foxit and Nuance (both up to date)

I made testfile (Scribus 1.4.6) with the these links (attached, sla and pdf):

It seems that here in our Acrobat the .ly links get a space after the dot like "www.bit. ly". It's what the Acrobat popup says: "http://www.bit". Other Links are working as expected.

I'm in an enterprise network and Acrobat is distributed by the admin.
Can someone please confirm that this is not a general Acrobat-problem, but version specific? Is what I think because Google hadn't any related results.

The writers here are in panic of non-working
I know it's not Scribus related directly, but is a good reason to finally register in this forum. :)

Thank's for any feedback!

Edit: Just checked it at home with Adobe Reader 11.0.18, all the same.

[attachment deleted by admin]
Miracles do not contradict nature – Miracles only contradict what we know about nature.
(St.Augustin, ?-604/605)


hi samuel

welcome in this forum!

i've reworked your .sla and tested it with both safari and adobe.

if you add http in front of the url, adobe will recognize the words as links and activate them as such.
i guess that "bit" is too short for that and other patterns exist that have three letters dot three letters dot two letters.

safari does not recognize any of them as links.

this being said, since you have not explicetely defined those links as links, it's up to the reading software to detect the links or not.

what you could do is to define a link in scribus. it's in the pdf tools. it's a very cumbersome process (of course: scribus has been created for generating pdfs that will be printed!) but it's there.
you have to draw a link frame on top of the area you want to be active in the pdf, double click the frame, define the web link and then it will work every where (except on paper, of course!).

so you have to choices:

- draw link frames everywhere,
- write "https://" in front of each url.

real links wil come some day...

groovy Kimo

Hi ale

Thanks for the nice answer. :)

I thought of the link frames, but using java is not an option to start with.

I have tried the links with http:// already, as I had the same thoughts. In the attached pdf sample "Test pdf links http_from scribus.pdf" is one *.ly link with http, one with https, one just with www: nothing works here in Acrobat (the popup says "http" for all links).

It seems to me that it's not the length, but the .ly domain that makes the links useless in Acrobat Reader.

I made a test pdf in word with the same links and pdf Crator, and -- it works in Acrobat Reader (the popup says "http" for all links too).

So it seems to me that Scribus renders *.ly links in a way that Acrobat cannot understand as link, despite http://.

Finally, a) my machine is quirky or b) it's a bug in Scribus?
Can you confirm that you can successfully convert the attached "Test pdf links http.sla" to pdf? And/or in both attached pdf the *.ly links work on your PC?

I'm not Techie enough to guess whether it's source-, pdf-writing or pdf-reading related. But in my view it points to Scribus?

Thanks, Samuel

[attachment deleted by admin]
Miracles do not contradict nature – Miracles only contradict what we know about nature.
(St.Augustin, ?-604/605)


you don't need java to use the link frames...

and my acrobat reader recognizes

and since i forgot to attach the sla: here it is...

[attachment deleted by admin]

groovy Kimo

Ok, your files work for me, thanks.

This you wont belive me probably -- I reproduced it many times:
It is font related. Infact, letter related. Call me crazy...

The failing font is Quadraat regular and regular italic. Bold and bold italic work.
(It's a professional, original payware otf font, our corporate identity,

It's about the letters l, i, I: If the domain starts with one of these, the link fails.
If the domain starts with any other letter, even 1, the link works.
See the attached pdf.

It also has to do with Scribus itself somehow because if I use Quadraat in Word, then pdf Creator, the links are working. I can send the font privately if someone is interested in finding out what's happening exactly here.

I have no clue, but think it's about hidden spaces the font/Scribus uses for spacing somehow...?

Do you mark the threads as solved here?


[attachment deleted by admin]
Miracles do not contradict nature – Miracles only contradict what we know about nature.
(St.Augustin, ?-604/605)


if you need that font you could try to produce the pdf with scribus 1.5.2 (only open copies of your document with 1.5.2, since if you save a .sla in 1.5.x you cannot open it anymore in 1.4!).

otf handling has been reworked and might better cover such cases.

scirbus 1.5 and 1.4 can be installed alongside.

groovy Kimo

Miracles do not contradict nature – Miracles only contradict what we know about nature.
(St.Augustin, ?-604/605)