Scribus > General Discussion

render frame latex and gnuplot

(1/2) > >>

La Raison:
Hi, everybody. (sorry for my poor english...)

I try to found the latex preamble in scribus render frame to debug and the place were is the latex log.

I also try to show in render frame a graph with gnuplot whitout success.

I receive the following error message (my traduction):
"gnuplot set output '%.png'" can't be launch. Check the path.

In console "gnuplot" terminal start.

thanks if you can help me,

Have a good day.

La Raison

a.l.e:
which OS?

how was gnuplot installed?

where is it installed? ("which gnuplot")

what is in your path? ("echo $PATH")

ciao
a.l.e

La Raison:
Hi, a.l.e

Thanks for your reply.

I use windows Vista,

After your questions, i try to understand gnuplot installation on my system.
Gnuplot is intalled, but probably in a funny way.
1. in C:\Program Files\gnuplot\bin
2. in xcas (math program)
3. in CygTeXmacs

then a try with Latex,

    \documentclass{article}
    \usepackage{tikz}
    \begin{document}
    \begin{tikzpicture}
    \draw[domain=0:10] plot function {sin(x)};
    \end{tikzpicture}
    \end{document}

And the pdf is good, i can see the sinus fonction.
Tikz is suppose to use gnuplot internally to display the plot.

Maybe it's the command i change in scribus :
gnuplot "set terminal png set output $scribus_file$.png"

(I can't found the initial command when i install Scribus.)

thanks

I wish you can help me with this informations.

La Raison

La Raison:
Hi, again

For my second problem : Render framed in LaTeX.

This is the error log i receive:

This is pdfTeX, Version 3.1415926-1.40.10 (MiKTeX 2.8)
entering extended mode
(C:/Users/Marcboss/AppData/Local/Temp/scribus_temp_render_yV3844
! Undefined control sequence.
l.2       \documentclass
                    [a4paper,11pt]{extarticle}
! Undefined control sequence.
l.3       \usepackage
                 [utf8]{inputenc}
! Undefined control sequence.
l.4       \usepackage
                 [left=0cm,top=0cm,right=0cm,bottom=0cm,nohead,nofoot]{geome...

! Undefined control sequence.
l.5       \title
            {Scribus-Latex-File}

Overfull \hbox (21.19067pt too wide) in paragraph at lines 2--6
[]\tenrm [a4paper,11pt]extarticle [utf8]inputenc [left=0cm,top=0cm,right=0cm,bo
ttom=0cm,nohead,nofoot]geometry|
! Undefined control sequence.
l.7       \usepackage
                 {amsmath}
! Undefined control sequence.
l.8       \author
             {Scribus}
! Undefined control sequence.
l.9       \pagestyle
                {empty}
! Undefined control sequence.
l.10       \setlength
                 {\textwidth}{84.78 pt}
! Undefined control sequence.
l.10       \setlength{\textwidth
                            }{84.78 pt}
! Undefined control sequence.
l.11       \begin
             {document}
! Undefined control sequence.
l.12    \section
              *{Introduction}
! Undefined control sequence.
l.13 Votre cadre \LaTeX
                        fonctionne lorsque vous pouvez lire ce texte !\\
Runaway argument?
 Placer des formules est très facile :\\ Clique droit $\Rightarrow $\ETC.
! Paragraph ended before \\ was complete.
<to be read again>
                   \par
l.23
     
)
! Emergency stop.
<*> ...pData/Local/Temp/scribus_temp_render_yV3844
                                                 
!  ==> Fatal error occurred, no output PDF file produced!
Transcript written on scribus_temp_render_yV3844.log.
texify: pdftex failed for some reason (see log file).

For me, it's like some garbage pollute the preamble, maybe?

Thanks

La Raison

La Raison:
Hi,

My experiments about gnuplot continue.

The command : "C:\Program Files\gnuplot\binary\gnuplot.exe" %file

run whitout error (I think) and the frame appear with a big red cross and "scribus_temp_render_yV4680.png"­

but the right plot name is "UsersMarcbossAppDataLocalTempscribus_temp_render_yV4680.png" without slash (\)! in the path : C:\Users\Marcboss\AppData\Local\Temp...

If you have an explication,

thanks

La Raison

Navigation

[0] Message Index

[#] Next page

Go to full version