Scribusoid

Author Topic: Times font insists on being embedded  (Read 3618 times)

bwelsher

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Times font insists on being embedded
« on: January 12, 2013, 02:40:35 am »
Hi all, when I come to export a document I have created to PDF I outline all the fonts used therein. Except for Times New Roman Regular which always appears under the 'Fonts to embed' section. Sometimes it can be removed using the adjacent arrow button, sometimes that button is greyed out. The kicker is that Times New Roman Regular isn't even used anywhere in the document as far as I can tell! (it's only 1 page).
Any suggestions to stop it being automatically embedded and thus increasing the file size?
Thanks!

utnik

  • Hero Member
  • *****
  • Posts: 1306
  • Karma: 14
Re: Times font insists on being embedded
« Reply #1 on: January 12, 2013, 02:51:06 pm »
hello bwelsher

sounds odd – could you provide a sample .sla file?

utnik

Nermander

  • Hero Member
  • *****
  • Posts: 1306
  • Karma: 17
Re: Times font insists on being embedded
« Reply #2 on: January 13, 2013, 11:31:21 am »
Even if a font is not used it will (unfortunaltely) get embedded if it is used in any style (even if the style is not used) OR the default font of any tool (check the Tools part under Document settings).

bwelsher

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Re: Times font insists on being embedded
« Reply #3 on: January 15, 2013, 01:52:55 am »
utnik - have PM'd you a link to one of documents where 'Times' is refusing to allow itself to be removed from the embedded list.
Nermander - I've changed the font under Document Setup>Tools to a font that is actually used in the document, saved and reopened but 'Times' is still sitting there in the Export PDF dialog not allowing itself to be un-embedded! None of the document styles seem to use Times either.

utnik

  • Hero Member
  • *****
  • Posts: 1306
  • Karma: 14
Re: Times font insists on being embedded
« Reply #4 on: January 15, 2013, 08:56:55 am »
hi bwelsher

just had a look at your file.
all the text frames are set as 'times new roman'. you only changed the actual content (not even the empty lines…) – and the 'subset' option for times new roman is unchecked in 'file' → 'document properties' → 'fonts', so, the whole font will be embedded.

utnik

bwelsher

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Re: Times font insists on being embedded
« Reply #5 on: January 15, 2013, 09:13:49 am »
hi bwelsher

just had a look at your file.
all the text frames are set as 'times new roman'. you only changed the actual content (not even the empty lines…) – and the 'subset' option for times new roman is unchecked in 'file' → 'document properties' → 'fonts', so, the whole font will be embedded.

utnik

Thanks for the reply. When I select a text frame the property box lists the font correctly as 'Minion Pro Regular' so I don't exactly follow what you mean. Also the 'subset' option appears checked for all fonts, to me anyway! Am I looking in the wrong place?

utnik

  • Hero Member
  • *****
  • Posts: 1306
  • Karma: 14
Re: Times font insists on being embedded
« Reply #6 on: January 15, 2013, 08:29:41 pm »
hi bwelsher

…the property box lists the font correctly as 'Minion Pro Regular'…
…the 'subset' option appears checked for all fonts…

when i look at it, the 'subset' option for times new roman remains unchecked and the frames are set to times new roman – the screen shot below shows the xml code of one of your text frames…

utnik

bwelsher

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Re: Times font insists on being embedded
« Reply #7 on: January 16, 2013, 03:04:21 am »
hi bwelsher

…the property box lists the font correctly as 'Minion Pro Regular'…
…the 'subset' option appears checked for all fonts…

when i look at it, the 'subset' option for times new roman remains unchecked and the frames are set to times new roman – the screen shot below shows the xml code of one of your text frames…

utnik

I checked the xml too and could see Times mentioned so checked the frames within Scribus again and lo and behold they were set to Times as you said. Changed them all to Minion or Myriad and looks like Scribus no longer wants to embed Times on PDF export.
Thanks for your help!