Scribusoid

Author Topic: Font technical issues  (Read 2763 times)

sunimasuno

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
  • Scribus User
Font technical issues
« on: December 30, 2012, 09:24:10 pm »
I'm attempting to use fonts from this site, http://www.acondia.com/fonts/index.html and getting mixed results. All of his fonts work in wordpad and word with no problems. His tengwar fonts work in all programs I have no problems. But the ones I most want to use, the Germanic rune fonts, do not work in either inkscape or sribus, the two programs I want to use them in.

Scribus displays only empty boxes where the characters for the font should be. Inkscape will not read that font as existing, despite having been installed alongside the tengwar font which works fine.

Any ideas/suggestions on how to fix this? My apologies if I'm posting in the wrong area. Thank you for your time!

Nermander

  • Hero Member
  • *****
  • Posts: 1305
  • Karma: 17
Re: Font technical issues
« Reply #1 on: December 30, 2012, 10:26:55 pm »
The only input I can give is that Scribus is very picky with the font. That the font works in other programs but not in Scribus is not a sign that it as a good font, rather the contrary. Other programs are less stringent in their font use so they can use "bad" fonts.

sunimasuno

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
  • Scribus User
Re: Font technical issues
« Reply #2 on: December 30, 2012, 10:53:14 pm »
Is there then a way to repair the font? Or perhaps to extract the data from the font and put it into a font that Scribus will accept? At least perhaps a way to see what about the font is causing it to be rejected?

sunimasuno

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
  • Scribus User
Re: Font technical issues
« Reply #3 on: December 31, 2012, 03:38:41 am »
^_^ Thanks for your reply. I've spent the afternoon chewing on this and I think I've figured out what the issue was, at least most of it. I'm mostly posting this for future people's help.

I downloaded Fontforge and opened the fonts. I got a TON of error messages on the fonts that were giving me problems. Also all of the usable characters were mapped to some really extreme values, with nothing mapped to the usual values. So I moved the mappings and used all of the default replacement settings from fontforge and that appears to have fixed it. Thanks for your time!

Nermander

  • Hero Member
  • *****
  • Posts: 1305
  • Karma: 17
Re: Font technical issues
« Reply #4 on: December 31, 2012, 01:58:41 pm »
I did not know Fontforge had such features, I tried to search for some font analysis tools but did not find anything free.

toyotadesigner

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 0
  • Active Scribus Mac User
Re: Font technical issues
« Reply #5 on: January 28, 2013, 09:40:18 pm »
I guess you can convert the font with fontxchange for Mac OS X. Scribus doesn't have any problems with OT fonts. I have some 3.000 fonts, roughly 500 converted from Type1 to OTF, none of them causes problems. Even two or three TTF fonts converted to OTF are running great. As long as the font will support the extended character set, you'll even get the German Umlauts like ä,ö,ü,ß or the Spanish ñ, etc. into your system.

So I guess that with Fontforge and fontxchange most of the users now will be able to clean weird fonts :-)