Scribusoid

Author Topic: Problem: XeLaTeX in render frame  (Read 2387 times)

t-brunner

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
  • Scribus User
Problem: XeLaTeX in render frame
« on: November 07, 2012, 12:37:33 pm »
Hello Forum,
I've been trying to use a render frame with XeLaTeX instead of LaTeX (which works perfectly well!), which means that I've changed the standard command /usr/texbin/pdflatex --interaction nonstopmode into /usr/texbin/xelatex --interaction nonstopmode, I've switched off the standard LaTeX preamble and use the following XeLaTeX template (which compiles smoothly in TexShop).

\documentclass[12pt]{article}
\usepackage{geometry}                % See geometry.pdf to learn the layout options. There are lots.
\geometry{letterpaper}                   % ... or a4paper or a5paper or ...
\geometry{landscape}                % Activate for for rotated page geometry
\usepackage{graphicx}
\usepackage{amssymb}
\usepackage{fontspec,xltxtra,xunicode}
\defaultfontfeatures{Mapping=tex-text}
\setromanfont[Mapping=tex-text]{Hoefler Text}
\begin{document}
My text\ldots
\end{document} 

Unfortunately, the render frame does not show the XeTeX page I would like to see but instead just displays the filename scribus_tem_render_xJL843.pdf. There is no error message, so the XeTeX compiler seems to work. I use Scribus 1.4.1 on MacOS.

Does anyone have a hunch what might be wrong?

Thanks,
Thomas


a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2175
  • Karma: 28
    • the graphics lab
Re: Problem: XeLaTeX in render frame
« Reply #1 on: November 11, 2012, 12:16:50 pm »
asking on the me mailing list may reach more *tex users...

ciao
a.l.e