Author Topic: Strange behavior with a PNG-Image  (Read 2229 times)

albert0346

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
  • Scribus User
Strange behavior with a PNG-Image
« on: November 01, 2012, 11:04:37 pm »
Hi,

I recognized a strange behavior with one of my PNG-Images:

I downloaded this image from my website with the function in the context menu and imported it then into an image frame. The image is 300 x 197 px, 96dpi. On my windows XP SP3 system it displays with the proper size, as on the Web. But on my Windows 7 system it has suddenly a resolution of 400dpi and therefore is way too small. How can a change to 400dpi can happen?

Could someone help me with this strange behavior? Your help is very appreciated.

Albert

Nermander

  • Hero Member
  • *****
  • Posts: 1311
  • Karma: 17
Re: Strange behavior with a PNG-Image
« Reply #1 on: November 02, 2012, 08:34:15 am »
The DPI is just a number calculated from the number och pixels and the physical size.

See the explanations in this topic http://forums.scribus.net/index.php/topic,112.0.html

So, as long as the image has the same number of pixels, just resize it and the DPI will change.

albert0346

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
  • Scribus User
Re: Strange behavior with a PNG-Image
« Reply #2 on: November 02, 2012, 10:36:28 am »
But when I resize it to the wanted size the image got blurred.

Albert

Nermander

  • Hero Member
  • *****
  • Posts: 1311
  • Karma: 17
Re: Strange behavior with a PNG-Image
« Reply #3 on: November 02, 2012, 12:37:03 pm »
In the PDF or in the screen preview? Scribus has a separate setting for the preview resolution.

If the image is 300 x 197 px it should still be 300 x 197 px no matter what version of Scribus you import it to, because Scribus does not embed images, it only links to them (just lika an IMG tag in a HTML document would do).

albert0346

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
  • Scribus User
Re: Strange behavior with a PNG-Image
« Reply #4 on: November 02, 2012, 08:38:49 pm »
As I mentioned in my first post, the behavior is different on both systems, and that's so strange.

When I change the size in the property window then the image got blurred.

Albert

 

palmate