Scribusoid

Author Topic: Scribus Doesn't See All My Fonts  (Read 4995 times)

SadieBlack

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Scribus Doesn't See All My Fonts
« on: May 24, 2012, 11:17:40 am »
I managed to get Ghostscript installed, and Scribus is running fine under Lion. However the list of fonts in the story editor doesn't include the massive number of Celtic fonts (admittedly old) that I have. Is there a way to get the program to see those fonts?

I also really don't need to see all the fonts Apple uses for localization in the list of fonts.

Thanks for any help offered!

Nermander

  • Hero Member
  • *****
  • Posts: 1267
  • Karma: 17
Re: Scribus Doesn't See All My Fonts
« Reply #1 on: May 24, 2012, 01:21:30 pm »
I don't know anything about how Scribus works under OS X, but there is information in the wiki on how to get Scribus to find additional fonts.

http://wiki.scribus.net/canvas/Installing_additional_fonts

Not sure if that information is up to date though.


SadieBlack

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Re: Scribus Doesn't See All My Fonts
« Reply #2 on: May 27, 2012, 07:54:44 am »
Thank you for that link. I went to Preferences and added the fonts but they still didn't show up.

Now I am wondering if Scribus doesn't like TrueType fonts, or prefers Postscript fonts, which require the suitcase and the PS file. TrueType is more modern and the icon for the fonts prefs says "TT," which leads me to believe TrueType is fine.

I'm stumped. Anyone?

Nermander

  • Hero Member
  • *****
  • Posts: 1267
  • Karma: 17
Re: Scribus Doesn't See All My Fonts
« Reply #3 on: May 27, 2012, 01:14:40 pm »
Did you restart Scrbius? As far as I know fonts are only read in att startup.

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1852
  • Karma: 26
    • the graphics lab
Re: Scribus Doesn't See All My Fonts
« Reply #4 on: May 27, 2012, 02:49:43 pm »
generally speaking, scribus likes true type fonts (better than ps fonts)...

... one thing: scribus does not like bad fonts, but i don't think this is your case...

ciao
a.l.e

SadieBlack

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Re: Scribus Doesn't See All My Fonts
« Reply #5 on: May 27, 2012, 10:50:21 pm »
Yes, I've restarted several times. Sigh.

Looks like these fonts must fall into the "bad" font slot. It's a bummer because my business logo needs one of them to work. Fontbook says they are okay. I'll post again if I ever get them to work and tell you how I did it.

SadieBlack

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Re: Scribus Doesn't See All My Fonts
« Reply #6 on: May 27, 2012, 11:08:47 pm »
Scribus appears to prefer the PS versions of these fonts. I tossed all the PS dupes in there along with the TT and voilá! I have working Celtic fonts again!

However the first part of my question, regarding telling Scribus which fonts NOT to use, is still out there. In the preferences you can click a check box to tell S which to load and which not to....but it doesn't work. They still all show up in all the font lists anyway.

However it's much better to have ALL the fonts than to have S not loading some you need!

Nermander

  • Hero Member
  • *****
  • Posts: 1267
  • Karma: 17
Re: Scribus Doesn't See All My Fonts
« Reply #7 on: May 28, 2012, 08:25:11 am »
When you have a Scribus document open, most preferences apply to that document only.

To make global changes to preferences you must change them with no document open.