Scribus > PDF Generation

PDF export and font embedding

(1/1)

mageejp:
Hi all,

So I just finished typesetting a 137pp. book, 6"x9". It's fairly illustration-heavy, but it's all single-color vector line art. The total .sla file size is only 14Mb.

Now, my question is this--I exported to PDF/X-3 and was not given the option of embedding my fonts (all four in the Univers family, all TrueType fonts). Instead, it converted all the text to outlines. When I tried adding the fonts to the 'embed' column, they jumped straight to the 'outline' column.

That seemed to work fine on my Mac, as I was able to open it quickly and easily with the native Preview. However, when I brought it to my office to print on a PC, Adobe Acrobat was barely able to even open it: it seemed to be laboring with the complexity of the file. Likewise, when I sent the file off to the print shop to run a proof, I was told their computer was freezing when the file was opened.

Any thoughts here? Is font embedding limited or unavailable in Scribus? Are there any work-around ideas?

Any help much appreciated.

Jon

Nermander:
Some types of fonts can not be embedded.

I think this might apply (from http://wiki.scribus.net/canvas/Help:Manual_Fontsconfig):


--- Quote ---OpenType Fonts - Unicode True Type Fonts cannot be fully embedded by default. This greatly simplifies handling them in other applications. OpenType Fonts and Unicode TrueType Fonts can be quite large, some larger than 10 Mb... OpenType Fonts/Unicode True Type Fonts are exported as outlines in PDF. This allows them to be used in PDF, where often other applications cannot use them. Moreover, embedding Open Type fonts is only supported in PDF 1.6+ (Acrobat 7.0.x) and this technology is quite new.
--- End quote ---

mageejp:
Ah, I see.

Do you have any ideas why the print shop was having such trouble opening the file? Should I just break the file into smaller chunks?

utnik:
hi jon

did you uncheck the 'subset' box? ('file' → 'document setup' → 'fonts' → the fonts, you're using – e.g. 'univers medium' → 'uncheck 'subset')…
on my system (scribus 1.4.0, mac os 10.6.8) this let me embed the font.

utnik

mageejp:
utnik,
Thanks for the tip. That did the trick!

Jon

Navigation

[0] Message Index

Go to full version