Scribusoid

Author Topic: fixed-width space?  (Read 5536 times)

Morda

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
  • Scribus User
fixed-width space?
« on: March 01, 2012, 02:48:55 am »
Hi!

I need an em-dash followed by a fixed-width space (in my language dashes in dialogues should be followed by spaces). There's no problem with the dash, but the space is impossible for me to obtain: I have tried many ways, but all I get is a space with variable width (since my text is justified, the changing width is showing a lot).

I tried to insert the space from the menu (Insert → Spaces and breaks → Non Breaking Space) both in Story Editor and directly in the text frame (a nice red underscore appears in the first case), I tried the "CTRL+Enter" combination, which should be the same - and actually is, since the result for me is the same :(   I also tried to import the space from MS Word (where the combination is CTRL+SHIFT+Space) - no luck either, the spaces are still of different width.

Is it possible that the font is to blame? I use Cambria and if there's no other option I can change it, but... how can I know whether a given font has or has not the space I need? How can this be checked? Please help.

I use Scribus 1.4.0.

Greets,

Morda

Meho R.

  • Full Member
  • ***
  • Posts: 198
  • Karma: 0
Re: fixed-width space?
« Reply #1 on: March 03, 2012, 01:06:30 pm »
I'm not sure if it's possible automatically, so you'll probably have to settle for manual approach: changing tracking in Properties Palette > Text > Advanced Settings. But still, having fixed spaces anywhere in text is a bad idea, since it will lead to visual issues on the page, especially if you're using em-dashes often. Rather than fixing the space width around em-dashes, you might consider correcting tracking manually only for those instances which look really bad, and left the others as they are.

Morda

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
  • Scribus User
Re: fixed-width space?
« Reply #2 on: March 06, 2012, 02:35:05 pm »
Meho R.: thanks for your comment.

Well, the problem is solved. I don't know why I got so fixated on the non-breaking space: if I had just have a quick look below in Insert → Spaces and breaks, there's an "em space" and an "en space" there - both with a fixed width, not affected by kerning nor justification, exactly what I need! How blind one can get sometimes :-[

Morda

Tartignole

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
  • Scribus User
Re: fixed-width space?
« Reply #3 on: February 14, 2014, 01:33:36 pm »
I have the same problem : in my language (french) we have to use, for good typography, fixed-width spaces (for example before : or ;)

The choices listed above (em-space, en-space) are always grey, whatever the font I use. This little thing makes Scribus very crippled in french.
Is it any hope that this very problem will be solved in the near future ?

Salvatos

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: fixed-width space?
« Reply #4 on: August 03, 2014, 08:16:35 am »
I had the same issue as Tartignole where these options are greyed out with every font I tried (I did not try all fonts for obvious reasons), but I found a workaround that may be useful to others.

1. Go to Insert > Characters...
2. Press the magnifier icon (Unicode search).
3. Search for "space" and make your pick (2002 for en space, 2003 for em space, but there are several more).
4. Double-click the desired space to place it in the first box in the character pop-up (it still looks blank because it's a space, but it's there).
5. Double-click that first box to insert the character in your text.

Tartignole

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
  • Scribus User
Re: fixed-width space?
« Reply #5 on: August 05, 2014, 04:45:48 pm »
Hello,

I did as you advise but this does not insert a space ; it inserts a white square, that means, I think "unknown character"...

Salvatos

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: fixed-width space?
« Reply #6 on: August 05, 2014, 04:59:52 pm »
I suppose it depends on your font's character set. I tried the above method again on a blue background and I'm not getting any white. Both the en space and em space yield a different spacing that integrates with the rest of the text. But switching to a font like Dingbats I do get blank boxes (even for "normal" letters) so these spaces are dependent on your font, not generated by Scribus universally.
I suppose a workaround would be to use a different font for your spaces (since there is no style consistency to worry about then). The ones I tried on Kinnari seem to work fine.

Tartignole

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
  • Scribus User
Re: fixed-width space?
« Reply #7 on: August 06, 2014, 09:53:46 am »
Thanks, it looks like it could work, with a few tryings : I have to find a font that includes these spaces, and find the right font size matching with my "visible" font...

 

palmate