Author Topic: Page Numbers not Rendering on Export  (Read 2329 times)

solaero

  • Newbie
  • *
  • Posts: 31
  • Karma: 0
  • Scribus Moonlighter
Page Numbers not Rendering on Export
« on: August 20, 2016, 05:01:25 am »
Scribus 1.5.2
Mac OSX 10.11.5

---

Exporting the document and page numbers are not printing. Not sure if I did something wrong or if it's a new "feature" of 1.5.2.

Actually, sometimes a couple page numbers show up, but not consistently. Otherwise the export seems to be fine.

---

Project is too large to attach here. Will have to post link to the project later. Hotel internet is pathetic.

[edit] link to project file and example pdf. https://www.dropbox.com/s/q28df3b37mfke1k/sample.zip?dl=0
« Last Edit: August 20, 2016, 05:23:33 am by solaero »

utnik

  • Hero Member
  • *****
  • Posts: 1448
  • Karma: 17
Re: Page Numbers not Rendering on Export
« Reply #1 on: August 20, 2016, 09:08:17 am »
hi solaero


i exported your file with the current settings (macOS 10.11.6 / scribus 1.5.2svn21331) and the page numbers are visible in my .pdf file – don't know why they are missing in yours…


utnik

bri_huang

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
  • Scribus User
Re: Page Numbers not Rendering on Export
« Reply #2 on: July 21, 2018, 01:17:29 am »
I just ran into the exact same problem. I found that if I save my file, close Scribus, and then re-open the file the page numbers render correctly on export. If I make any edits or changes and then try to export to PDF, I get errors on the pages with page numbers and the numbers don't render. I don't know what's going on here, but this is a workable solution for me.

TLDR - My fix was to close and re-open Scribus. Now, open your file, but don't make any changes, export your file to PDF.

jack_cat

  • Full Member
  • ***
  • Posts: 113
  • Karma: 1
  • Scribus User
Re: Page Numbers not Rendering on Export
« Reply #3 on: June 23, 2020, 03:26:10 pm »
This is a bug in 1.5.2. There is a bug report here:

https://bugs.scribus.net/view.php?id=14117
The way this showed up for me is that many 3-digit pages numbers are
printed with one or two missing characters (never the first digit) represented by a box.
The missing digits vary from one PDF export to the next, but in patterns such as
no 8s print as the second digit.

It is supposed to be fixed in 1.5.3.
The method of closing and reopening the file, which Bri_Huang said
worked for him, gives worse results for me!  - none of the 3 digits print!

Somebody posted on another thread that the workaround is to print to a separate
PDF printer instead of using Scribus's own PDF export. This didn't work for me on the
first try using PDF995; in this case Scribus went into a loop of trying to export some
piece of data, and I had to cancel; then the PDF printed the first page and an errror message.
Scribus refused to print successfully to PDF995.

I was successful when I used Foxit PDF printer instead. All the page numbers
are fine. Hallelujah. So, all print-to-PDF programs are not the same to Scribus.
BUT this is still not a perfect solution: the flaw only showed up when I concatenated
all of the chapter PDFs, and then it appeared that Foxit's 8.5x11 page is not quite
the same size as Scribus's 8.5x11 page, but showing up on the screen a few pixels
smaller. I don't know what will happen when this concatenated PDF is printed on paper.

Following this I spent another hour or so adjusting the page size in Foxit PDF  printer
by trial and error, and the page size 8.27" x 11.70" makes the concatenated PDF
pages match up at the same size as the ones I previously had exported (with
no problems, by the way) from Scribus 1.5.2 using the similar files of the previous
five chapters.

The funny thing is that I have converted six files from 1.4.6 to 1.5.2 recently and
in the first five the page numbers printed correctly. This file is bigger and has more
graphics. It may be a matter of switching over to 1.5.3. I haven't been able to make
1.5.5 work on my old Windows 7 machine because of a .dll that I can't find.
However, it appears that I do have a workaround now.
jack
« Last Edit: June 23, 2020, 04:30:09 pm by jack_cat »

jack_cat

  • Full Member
  • ***
  • Posts: 113
  • Karma: 1
  • Scribus User
Re: Page Numbers not Rendering on Export
« Reply #4 on: June 23, 2020, 07:47:44 pm »
As it happens, that's not the end of the story. After I finished with the file
I was working on in my previous post above, I went on to open another
file which I had created in Scribus 1.4.6, and saved it in my new folder with
Scribus 1.5.2. This time I wanted to do a total revision, and so after doing
"collect for output" I just deleted all except page one, leaving all the image files
handy in the new "images" folder, and then I generated a set of 24 new pages.
I also reset the page numbering to match previous chapter revisions.
Now, the first and second pages are numbered 143, and all the other pages are numbered
144. Ha. This is NOT only in the exported PDF - it's in the Scribus file! I haven't seen this
glitch before.

I am first going to re-build the file from scratch in 1.5.2 and see if I have the same difficulty.
I will hope to be able to import master pages and styles from the preceding chapters.
(This is probably all fixed in 1.5.3, I may have to try that version.)
« Last Edit: June 23, 2020, 07:50:07 pm by jack_cat »