Author Topic: Can't see Dingbats & other symbols  (Read 9707 times)

cliffskier

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Can't see Dingbats & other symbols
« on: January 14, 2012, 12:09:11 pm »
I am new to Scribus. I am trying to create a bullet list using a Dingbat or Wingding character for the bullet, but all I see are red square outlines when I use those fonts. The Preflight Verifier reports an error, "Glyphs missing [black box] Background." Ordinary letter fonts do not produce this error.

My Wingdings work in other programs. I can even see them in the Story Editor dialog if I choose Wingdings as the display font--but they still don't show up in the text frame.

I am using Scribus 1.4.0 in Windows 7. I have searched everything I can think of, but can't find any info about this problem. Any tips on how to use these fonts?

Cliff

Wena

  • Full Member
  • ***
  • Posts: 179
  • Karma: 0
Re: Can't see Dingbats & other symbols
« Reply #1 on: January 14, 2012, 12:16:33 pm »
Try saving a small peace to a PDF file to see if there is what you want. What you see on screen is not always what you get.

Wena
« Last Edit: January 14, 2012, 09:09:21 pm by Wena »

cliffskier

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Re: Can't see Dingbats & other symbols
« Reply #2 on: January 14, 2012, 10:05:09 pm »
If I export to a PDF file, the Wingdings characters are invisible. Text in another font looks normal.

Cliff

Nermander

  • Hero Member
  • *****
  • Posts: 1246
  • Karma: 16
Re: Can't see Dingbats & other symbols
« Reply #3 on: January 15, 2012, 06:10:26 pm »
How do you get the bullets? Copy and paste from another program?

Scribus only uses the glyphs that are available in the font used, so your must probably create a character style using the right font and use that style for the bullets.

cliffskier

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Re: Can't see Dingbats & other symbols
« Reply #4 on: January 15, 2012, 11:41:15 pm »
I just select the Wingdings font from the drop-down list in Story Editor. Or, while experimenting, I have also specified Wingdings in the properties box for my text frame. Then I type the letters corresponding to the symbols I want. If I want a snowflake I type a capital T. If I want a round bullet I type a lower case L.

I have also tried typing the Wingdings character I want in Word and pasting it from there into Scribus. Same result. Although I have just discovered that the one thing that does work is to create a text frame, set the font as Wingdings in the properties box, copy my characters from Word, and paste them into the frame. If there is any other text in a different font in the frame, or if I try to add text in a different font in the same frame, the Wingdings disappear. But even if the frame is empty with Wingdings as the default font, I cannot get them by typing directly in the frame. It also doesn't work to copy the characters from the Windows Character Map and paste them into my Scribus frame, although it does work to paste them first in Word, then copy from Word and paste into Scribus.

So if nothing else I could create a separate text frame one character wide to the left of my list frame and put my bullets in that frame by copying them from Word.

Cliff

Meho R.

  • Full Member
  • ***
  • Posts: 198
  • Karma: 0
Re: Can't see Dingbats & other symbols
« Reply #5 on: January 16, 2012, 02:43:40 am »
1. Check How to create lists in Scribus article (don't miss the video).

2. Now that you got some ideas about creating lists, here's a simple variant. Create a text frame, put some text there, double-click on the frame, put the cursor at the beginning of a paragraph, then go to Insert > Glyph > Hide/Show Enhanced Palette (the first icon) > choose "Wingdings" font > double-click on a symbol you like > press "Insert" button.

Of course, the situation in the text frame is as you described it: a red square instead of the chosen glyph. The reason is simple: inserted symbol inherited text style of the paragraph its in.

3. So, to "activate" the symbol, you have two options:
  • select the symbol (or, to be precise, the red box), press F2 to bring up Properties palette, go to Text tab and select "Wingdings" font from the drop-down list; or
  • select the symbol/red box, press F3 and create a new character style, set font to "Wingdings" and in Properties palette > Text > Style Settings choose this newly created character style from the drop-down list for "Character Style".

cliffskier

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Re: Can't see Dingbats & other symbols
« Reply #6 on: January 16, 2012, 10:46:53 am »
Thanks. That was really helpful. I can make it work now. Although I am a little confused about when the properties palette applies to the entire frame and when it applies only to selected text. I suppose I will get a more intuitive understanding of that with experience. :)

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1761
  • Karma: 26
    • the graphics lab
Re: Can't see Dingbats & other symbols
« Reply #7 on: January 16, 2012, 06:37:39 pm »
hi

if the frame is selected and you're not in edit mode, the formatting will be aplied to the whole frame.

if you're in edit mode (after having double clicked on the frame), the formatting will be applied to the place where you are (for char formatting) and will be visible as soon as you type some characters or the current paragraph (for paragraph formatting like the alignment)

if you select a word, a sentence or several line, the formatting will be applied to a selection.

and then there is the case, where you apply the formatting to the end of the text in the frame... it won't work: you have to live with it... there are philosphical reasons why it (does not) work that way, and it will be hard to get scribus to behave in a more sane way. but, who knows? maybe we will see a miracle one day?

ciao
a.l.e