Author Topic: Mac wants me to update  (Read 888 times)

Retired-Robin

  • Newbie
  • *
  • Posts: 13
  • Karma: 0
  • Scribus User
Mac wants me to update
« on: January 13, 2020, 10:28:59 pm »
My mac, running OS High Sierra 10.13.6 keeps wanting me to update. I use an old scribus/aqua (c) 2005-2013, if I update is there a Scribus download that will be compatible please?

utnik

  • Hero Member
  • *****
  • Posts: 1382
  • Karma: 14
Re: Mac wants me to update
« Reply #1 on: January 14, 2020, 06:08:37 am »
hi robin

if you update your system to 10.14 (mojave), you can use scribus 1.4.8 or 1.5.5 (or even 1.5.6.svn). but as soon as you update to 10.15 (catalina), you need to use scribus 1.5.?, as catalina doesn't support 32 bit applications any more.

utnik

Retired-Robin

  • Newbie
  • *
  • Posts: 13
  • Karma: 0
  • Scribus User
Re: Mac wants me to update
« Reply #2 on: January 14, 2020, 12:11:37 pm »
Thank you for your reply. As I am in my middle 70's and not now doing any complex stuff I think I will leave things as they are. As an ex Quark Xpress user I find Scribus easy to navigate which has been a huge bonus for the last few years.