Scribusoid

Author Topic: Can't install scribus on Ubuntu 19.10  (Read 3313 times)

medmedin2014

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Can't install scribus on Ubuntu 19.10
« on: November 27, 2019, 12:26:12 am »
I added scribus ppa to my Kubuntu 19.10, then after updating the sources I tried to install scribus-ng (newest version 1.5.5) but I got the following error :
Code: [Select]
sudo apt install scribus-ng
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 scribus-ng : Depends: libopenscenegraph-3.4-131 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The package libopenscenegraph-3.4-131 is available in the repository but it depends on other old package not available in Ubuntu 19.10
Code: [Select]
libopenscenegraph-3.4-131 :
                Depends: gdal-abi-2-4-0
                Depends: libgdal20 (>= 2.3.0) but it is not going to be installed
How can I install the latest version 1.5.5 on my machine ? I don't want to use those slow and fat standaone AppImage files !
« Last Edit: November 27, 2019, 12:27:58 am by medmedin2014 »

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2343
  • Karma: 33
    • the graphics lab
Re: Can't install scribus on Ubuntu 19.10
« Reply #1 on: November 27, 2019, 09:59:34 am »
"funny" : - )

the other day, i was chatting with our debian maintainer and said that depending on OSG adds a huge number of packages in the dependencies and basically nobody uses it from inside of scribus.

i've installed scribus-trunk on ubuntu 19.10 on monday, so i think that it should normally work and it's probably a temporary issue, until the dependencies of OSG are fixed.
from what i read in your error messages, it might be that another program you have installed keeps libgdal to an older version and OSG wants a newer one...

of course, the "fast" alternative is to compile scribus yourself... or use the appimage until the dependencies get fixed.

medmedin2014

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Re: Can't install scribus on Ubuntu 19.10
« Reply #2 on: November 27, 2019, 12:21:58 pm »
The libgdal is not even installed on my machine.

I installed the appimage version, but the mouse is always flickering and changes from hand to pointer when hovering over any shape (this is similar behavior that I found and still exist on windows 10-1909), this makes working with scribus impossible for me, the dark theme is really inconsistent and can't see most of checkboxes

I really need to use version ng or trunk because I have to modify my CV (created with scribus-ng) to send it to certain company this week.

I found that libgdal depends on libodbc1 and odbcinst1debian2 which both needs
Code: [Select]
libodbc1 : PreDepends: multiarch-support but it is not installable
odbcinst1debian2 : PreDepends: multiarch-support but it is not installable

I have 64bits machine, so does scribus need some 32bits libraries ? I used to have Ubuntu Mate for many years but scribus was installed from ppa and never needed any 32bits library !

medmedin2014

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Re: Can't install scribus on Ubuntu 19.10
« Reply #3 on: November 27, 2019, 12:44:27 pm »
I found that Ubuntu 19.10 can't run any 32bits apps/libraries, the 32bits support was removed from 19.10 and 20.04 and there is no way to install multiarch-support package even after enabling i386 architecture.
Code: [Select]
@kubuntu-med:~$ sudo dpkg --add-architecture i386
@kubuntu-med:~$ sudo apt update
....
@kubuntu-med:~$ sudo apt install multiarch-support
...
Package multiarch-support is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package 'multiarch-support' has no installation candidate

https://ubuntu.com/blog/statement-on-32-bit-i386-packages-for-ubuntu-19-10-and-20-04-lts
How can we use the software on our 19.10 machines ?

medmedin2014

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Re: Can't install scribus on Ubuntu 19.10
« Reply #4 on: November 28, 2019, 10:48:19 pm »
I resolved the problem by downloading the deb package multiarch-support from Ubuntu 19.04 and then after installing it I was able to install scribus-ng.
https://pkgs.org/download/multiarch-support
The problem is that package mutiarch-support which is required for libopenscenegraph was removed from 19.10 in attempt to abandon all 32bits libraries from Ubuntu in the future.

NB : The appimage is really full of bugs and not stable for use, it crashed and the mouse flickers while moving objects and is really slow to use in comparison to the installed version from ppa.
Please Please Please keep the ppa alive for future use, we really need it because those big/fat standalone apps (appimage, snap or flatpack) are full of bugs and slow to use.

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2343
  • Karma: 33
    • the graphics lab
Re: Can't install scribus on Ubuntu 19.10
« Reply #5 on: November 29, 2019, 01:27:13 am »
hi medmedin

of course the ppa is (very well) maintained!
and will not disappear anytime soon.

as i wrote in a previous post, the problem is not at all with scribus, but you seem to hit a issue with the packaging by debian of one of the dependencies of a dependency.

there is nothing scribus can do and it's very likely that it's a matter of time before it is solved.

i also downloaded the current appimage of trunk and i could not see any flickering nor could i see any bug.
i'm involved in maintaining the appimage for scribus and i don't see how it could be full of bugs.
can you be more specific?
did you try the nightly appimage or an old one?

concerning the speed, the appimage should not be much (if at all) slower than scribus as installed by other means. it's exactly the same code.
it will start a bit slower, since it needs to first unpack the files, but on my machine it does not make much of a difference.
of course, under some circumstances, it will require more memory than other types of executable.
but it should not be much more than scribus requires on macos or windows.
(so, if you don't have much memory it can be slower... yes...)

also, a few days ago i have successfully installed the trunk ppa.
i have now tried to track the dependencies from here: https://packages.ubuntu.com/eoan/libopenscenegraph100v5 and i could not find a package that is mandatory *and* cannot be installed.
but i did not see any pre-depends either...
and from what i can tell multiarch-support has never been in 19.10... and i really can't think that the ubuntu folks will be removing a package after a release is done.

you seem to have more issues than the average user...
and the fact that you have now installed the multiarch support from a different source, let me wonder if you haven't done similar things in the past and made your system unstable...

if i were you, my next try would be to setup a fresh virtual image with the latest ubuntu and install there the ppa...
(and i would have done that before adding "foreign" packages...)

medmedin2014

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Re: Can't install scribus on Ubuntu 19.10
« Reply #6 on: November 29, 2019, 02:12:38 am »
I use fresh install of Kubuntu 19.10, and I installed only some basic apps in the normal way, and my system is stable, the only problem I got is with scribus and digikam(older v5), both need that specific package which my new fresh install didn't have.
I posted a problem to seek a solution, because I used to install scribus on Ubuntu MATE for more than 5years without any problems.
My machine runs android studio and many eclipse instances and bunch of heavy apps, perhaps the appimage of scribus is heavier and needs faster machine.

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2343
  • Karma: 33
    • the graphics lab
Re: Can't install scribus on Ubuntu 19.10
« Reply #7 on: November 29, 2019, 11:45:53 am »
dear medmedin,

personally, i don't know how kubuntu and ubuntu studio diverge from the "real" ubuntu.

but before bothering our lovely and dedicated ppa maintainer, i've created a virtual machine with a minimal ubuntu 19.10, updated everything, added the scribus ppa, installed scribus-trunk and

it took some time but

oh la la!

it just works.
it installs, it runs, it's a bit slower than usual, but it's a VM on an "older" computer.
no need for 32 bit layers.

i also downloaded the appimage in the vm: well, it also works.
i get some flickering. but on the cursor when hovering a selected item (i get the same flickering with the PPA... and there is a ticket for it).
when moving items, there is no real preview, but no flickering either.
if i increase the monitor resolution, moving around items is not really smooth... but i still don't see a flickering.
no idea if we can make it smoother...
but i don't see a big difference between the PPA and the Appimage.

i'll let you check what the differences between -ng and -trunk are (there should be none concerning OSG) and between kubuntu, ubuntu studio and the mainline ubuntu...
i think i've spent enough time on this for today...
« Last Edit: November 29, 2019, 04:56:21 pm by a.l.e »

medmedin2014

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Re: Can't install scribus on Ubuntu 19.10
« Reply #8 on: November 29, 2019, 04:47:29 pm »
Thanks man, sorry if I wasted your time, it's just I love open source softwares, and I love scribus because it helped me a lot and I want to help developers by reporting bugs.
Thanks for your help and hard work ;)

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2343
  • Karma: 33
    • the graphics lab
Re: Can't install scribus on Ubuntu 19.10
« Reply #9 on: November 29, 2019, 06:45:35 pm »
concerning the flickering of the cursor: i have a first patch...

https://bugs.scribus.net/view.php?id=15869

solves only some of the flickerings of the mouse...