Scribusoid

Author Topic: Asking for substitution for installed font  (Read 331 times)

JBelizzle

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Asking for substitution for installed font
« on: September 03, 2019, 09:37:12 pm »
I have a project that I built out in Scribus on one computer using a font called "Chinese Dragon Regular" for titles (attached for reference). I got a new machine and installed the exact same font file to the new machine (I always save fonts with the associated project). When I try to open the file it tells me that Chinese Dragon Regular is not installed on my system and wants me to pick a substitution.

Here's what's weird though; not only is the font installed on the system, but if I close out of the substitution dialog and go to Fonts in Scribus' preferences menu, Chinese Dragon Regular shows up in the list of available fonts. However, if I open a different project and check the Font Preview tool, it doesn't show up in the list.

Anybody have any idea what could be going on here?

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2175
  • Karma: 28
    • the graphics lab
Re: Asking for substitution for installed font
« Reply #1 on: September 04, 2019, 08:32:03 am »
the font does work correctly here.

if you don't see the font when you create a new document, it means that you probably did not install it "correctly".
in the document which was already using it, you probably see it with an "s" (for "substitution") attached to it.

you should check how to install the fonts on your system, so that every application sees them (on windows you might need to install them as administrator).

utnik

  • Hero Member
  • *****
  • Posts: 1319
  • Karma: 14
Re: Asking for substitution for installed font
« Reply #2 on: September 04, 2019, 02:35:30 pm »
is the font checked to be used in documents? (under 'preferences' → 'fonts')

utnik

JBelizzle

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: Asking for substitution for installed font
« Reply #3 on: September 04, 2019, 03:22:22 pm »
The administrator install was the issue, thanks a.l.e!

It's odd to me that when the font is installed under my account Scribus recognizes it in the Preferences font list, but then is not able to access it for actual use.