Author Topic: Text colours missing in exported PDF  (Read 124 times)

davez5

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Text colours missing in exported PDF
« on: August 21, 2019, 12:38:41 pm »
Hi, when I export to PDF, the text loses its colours, and also the page background colour disappears. When I export to image, the text retains its colours, but the background colour still disappears.

I imported the x11.xml colour swatch (?) from the installation directory (Windows 10), could this be causing the issue?

I've Googled but although there's plenty out there about colour management (way over my head) I couldn't find anything that seemed relevant to this issue.

Thanks for any help, it was all going swimmingly until now!

utnik

  • Hero Member
  • *****
  • Posts: 1305
  • Karma: 14
Re: Text colours missing in exported PDF
« Reply #1 on: August 21, 2019, 04:09:28 pm »
hi dave
  • i couldn't find anything strange with the color of the text.
  • the rectangle called 'BackgroundP1' is deactivated for the export. (it's the small printer icon in 'properties' → 'x, y, z')
utnik

davez5

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Text colours missing in exported PDF
« Reply #2 on: August 21, 2019, 04:48:37 pm »
Thanks, I thought that would at least bring the background colour back, but no. The pdf has colour in the images, but the rest of the document is black and white. I've attached a screencap of the pdf file generated by Scribus.

davez5

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Text colours missing in exported PDF
« Reply #3 on: August 21, 2019, 05:03:51 pm »
Actually, for image export, the background is fixed, so images are exporting perfectly - coloured background frame, coloured text. But PDF still gives white backgrounds and black text.

RodneyLee

  • Full Member
  • ***
  • Posts: 138
  • Karma: 2
  • Scribus User
Re: Text colours missing in exported PDF
« Reply #4 on: August 21, 2019, 05:59:10 pm »
I just tested your SLA file, once I enabled printing it appeared to work just fine, Background saved to pdf, I didn't have your font so that didn't work

RodneyLee

  • Full Member
  • ***
  • Posts: 138
  • Karma: 2
  • Scribus User
Re: Text colours missing in exported PDF
« Reply #5 on: August 21, 2019, 06:13:39 pm »
as you can tell I had wrong fonts, the colors did come thru fine though

utnik

  • Hero Member
  • *****
  • Posts: 1305
  • Karma: 14
Re: Text colours missing in exported PDF
« Reply #6 on: August 21, 2019, 07:43:42 pm »
hi dave

i don't know what happens on your system.
whe i export it with your current settings, (i changed the export setting for the background,) it looks fine. see my screenshot of the .pdf file. (the exported file itself is too big for a forum upload.)

utnik

davez5

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Text colours missing in exported PDF
« Reply #7 on: August 21, 2019, 10:11:08 pm »
Well, thanks so much for everyone engaging with my issue. It does look like something very specific to my particular machine. At least now I know it should work and it does work, just not on my laptop. That's actually very helpful. If I figure it out I'll update here.

davez5

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Text colours missing in exported PDF
« Reply #8 on: August 22, 2019, 09:22:46 am »
So I finally figured it out, the issue was nothing to do with Scribus, it was an accessibility setting in Acrobat which replaces document colours with black and white. Thanks for all the help!