Scribusoid

Author Topic: Book format missing from template list  (Read 606 times)

jama251

  • Newbie
  • *
  • Posts: 16
  • Karma: 0
  • Scribus User
Book format missing from template list
« on: July 31, 2019, 09:40:24 am »
As my subject says, File<New from Template<... no book option present. Am working in B5, have tried going to A5 and A4 to see if it was a size issue but no. Have tried searching the forum but can't identify a post about this issue. Have used Scribus for a few years now and not encountered this before. Am working on Ubuntu as a recent setup on an iMac machine. (can't see this is the issue but always worth mentioning).
 Any signposts or advice gratefully received.

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1993
  • Karma: 26
    • the graphics lab
Re: Book format missing from template list
« Reply #1 on: July 31, 2019, 11:38:29 am »
hi jama,

if you're creating a book, you probably don't need any of the templates distributed with scribus.

it's likely that you need to create a document that matches your print shop requirements.
if they're very kind they will provide a scribus template or a scribus sample documents, otherwise, they will provide a set of measurements (margins, bleeds, ...) you should apply to your document.

it's hard to say if you really might profit from  a template: what exactly are you trying to produce and why are you looking for a template?

ciao
a.l.e

jama251

  • Newbie
  • *
  • Posts: 16
  • Karma: 0
  • Scribus User
Re: Book format missing from template list
« Reply #2 on: August 04, 2019, 12:16:58 pm »
Many thanks for your response. I am working with my print shop and their instructions on the required template as you suggested.

My problem is that I am producing a B5 format with a deja-vu sans book font size12. No matter how much I try, the settings I set in preferences do not seem to be able to hold in my text editor and it continually resets to what appear to be "defaults". In the properties dialogue box there is no deja-vu sans book font so no joy working there.

I therefore wondered if a book template would assist. However, books is not in the template list. Has Scribus just dropped Books from the template list?

I love my Scribus, I have produced lots of material using Scribus but my Scribus today is not doing what it is meant to do and has always done in the past. I am now over two hours into trying to get my pages to display deja-vu sans book font at size 12. I have tried every trick I know. I have two pages at my required display whilst the others are refusing all instruction from text editor to change.

Any advice truly welcome. I am at the stage of removing Scribus and trying a re-install.


jama251

  • Newbie
  • *
  • Posts: 16
  • Karma: 0
  • Scribus User
Re: Book format missing from template list
« Reply #3 on: August 04, 2019, 01:28:42 pm »
Supplemental:

Have managed to resolve the text issue as deja-vu sans has suddenly appeared in the properties<text dialogue. The text editor is still refusing to take instruction! However, suddenly, one of my pages grew to a larger size than the rest. I decided to delete it and then insert another page from the menu page<insert. This is now inserting the larger page format. I have gone over this a few times, checked my preferences, nothing has changed, everything is at it was.

I think I have nuts and bolts loose in my Scribus! Normally I work on Scribus on a desk top running Windows 7 pro. I am in another office where I have recently, three weeks ago, installed Ubuntu as the operating system on an i-Mac. So this is a brand new system, absolutely next to zero chance of any bugs on the system.

I think this now has to be a re-install unless you have any suggestions otherwise. Your view much appreciated.

Nermander

  • Hero Member
  • *****
  • Posts: 1296
  • Karma: 17
Re: Book format missing from template list
« Reply #4 on: August 04, 2019, 05:59:16 pm »
In Scribus there are two sets of settings, one for the current document, one that is used only when starting new documents.

If you want to change something for the current document, you need to use Document setup, not Preferences.

jama251

  • Newbie
  • *
  • Posts: 16
  • Karma: 0
  • Scribus User
Re: Book format missing from template list
« Reply #5 on: August 04, 2019, 06:01:03 pm »
Yep, did that.

jama251

  • Newbie
  • *
  • Posts: 16
  • Karma: 0
  • Scribus User
Re: Book format missing from template list
« Reply #6 on: August 04, 2019, 06:12:06 pm »
The attachment screen shots here should really make clear what my issue is. Any help or suggestions really welcomed because I need to get on with my writing. Anyone sorting this out will get a credit in this next book and probably citing them as an 'angel'.

jama251

  • Newbie
  • *
  • Posts: 16
  • Karma: 0
  • Scribus User
Re: Book format missing from template list
« Reply #7 on: August 04, 2019, 06:15:32 pm »
Oh yes, and just so you know that preferences and document are dealt with:

utnik

  • Hero Member
  • *****
  • Posts: 1291
  • Karma: 14
Re: Book format missing from template list
« Reply #8 on: August 04, 2019, 08:52:09 pm »
hi jama

if you could show me your .sla file (pm), i would try to solve the page size issue.

utnik

jama251

  • Newbie
  • *
  • Posts: 16
  • Karma: 0
  • Scribus User
Re: Book format missing from template list
« Reply #9 on: August 05, 2019, 11:46:02 am »
Thank you so much. How do I go about getting the file to you?
very appreciative.
Jack.

utnik

  • Hero Member
  • *****
  • Posts: 1291
  • Karma: 14
Re: Book format missing from template list
« Reply #10 on: August 05, 2019, 11:53:40 am »
hi jack

just click my username on the left of this post and you'll find the clickable entry 'Send PM'.

utnik

jama251

  • Newbie
  • *
  • Posts: 16
  • Karma: 0
  • Scribus User
Re: Book format missing from template list
« Reply #11 on: August 05, 2019, 01:27:33 pm »
Sorry Utnik, I realise I may be a bit dense here but I can't see any attachment facility on a PM. Screenshot attached. I have put the .sla on this and it is mostly stripped out of the content to make the file size reasonable.

Thanks again.

Jack.

jama251

  • Newbie
  • *
  • Posts: 16
  • Karma: 0
  • Scribus User
Re: Book format missing from template list
« Reply #12 on: August 05, 2019, 01:59:51 pm »
Utnik,

Whilst you are looking at that I can flag up another two issues which are slightly problematical.

Attached is a screenshot which shows a page and the properties box. This is the same file as the one you are looking at. Despite all settings stating font size as being 12, when typing into a text box in the document the font size is 14. This is also what shows in the properties<text box.

Not a huge issue as I can re-size but every time I type a new paragraph it resets to 14. Then I have to re-size. I have 200 pages of text for this book and that does tend to irritate.

On the second point, when I open my file I see a dialogue box which advises of replacement fonts. I tick the box marked "make this change permanent" but every time I open the file the same dialogue box appears.

Again, not critical but maybe something worth tweaking.

My real concern is that I've never had these problems with Scribus before. I always look to myself first as the cause of any issue as a matter of practice but here I am just lost. If it is down to me I would really like to know as much as if it is another problem then I would like to fix that.

Thanks again for your support. Very much appreciated.

Jack.

utnik

  • Hero Member
  • *****
  • Posts: 1291
  • Karma: 14
Re: Book format missing from template list
« Reply #13 on: August 05, 2019, 02:03:41 pm »
hi jack

yes, i was wrong. you can't attach files to a pm. (you would have to upload them somewhere and send a link…)
…but now i have your file – and i can see your problem.

your file is generated in A5, but you changed the page size to B5 in the document setup. that's why the first page is displayed with an offset (to give room for an inexistent left page in B5…)

if you intend to change the file size, you need to check 'apply changes to all pages' and 'apply changes to all master pages'.
…but this won't change the size of the text frames. you have to do this manually. (check 'page'
→ 'snap to guides'
first.)
or – as your file structure is very basic, you might prefer to generate a new file with the correct settings and copy the content.

edit:

your 'default character style' is set to dejavu sans book 14 pt. (you should work with styles anyway…)
when you type at the end of your text, the format of the frame will be applied – and as you didn't change this, it will be 14 pt.

i'm not sure about the font substitution issue.
  • did you try to replace the missing font by itself or by another font which isn't permanently available?
  • is there a special mark/icon with the selected font?

utnik
« Last Edit: August 05, 2019, 02:20:27 pm by utnik »

jama251

  • Newbie
  • *
  • Posts: 16
  • Karma: 0
  • Scribus User
Re: Book format missing from template list
« Reply #14 on: August 05, 2019, 05:16:25 pm »
Thanks Unik,


"...your file is generated in A5, but you changed the page size to B5 in the document setup. that's why the first page is displayed with an offset (to give room for an inexistent left page in B5…)"

I have not the slightest idea how this could have happened and wonder how this situation occurred after I had created the file and been working in it for a while. From creation to the moment the A5 page appeared, everything was working ok. That was about an hour, possibly more. I am not doubting what you are saying but wondering what it is I have done to suddenly create this issue. How do I generate a file in A5 when all the preferences and document set up are in B5?

This is just a matter of interest because I have already done what you have said and created a new B5 file and am working from scratch again in that. I just do not want to make the same mistake somewhere down the line. If you have time to explain this to me then I would be grateful but as you have done a lot already I totally understand if you want to just move on. Not a problem here with that.

"...your 'default character style' is set to dejavu sans book 14 pt. (you should work with styles anyway…)
when you type at the end of your text, the format of the frame will be applied – and as you didn't change this, it will be 14 pt."


Not sure what default character style is after having set all the preferences and document setup to 12 but I will search this out and deal with it. Thanks for the signpost on this.

i'm not sure about the font substitution issue.

    did you try to replace the missing font by itself or by another font which isn't permanently available?
    is there a special mark/icon with the selected font?


The dialogue box comes up and offers the option. I go to the drop down menu, select an available font and then tick the "make change permanent" option. This is not something that has happened with just Deja-vu, it has also happened with Ariel. I select an available option, I tick the box but it never makes the change permanent.

Again this is not such a big deal but it might be something useful for you guys to know.

Thanks ever so much for your assistance. When I get to publish in September I will put a thank you in my credits page for you and happy also to recognise Scribus as the tool of choice for production. Just let me know if that is ok with you.

Best wishes from Tokyo.

Jack.