Author Topic: Hyphenation in 1.5.4 doesn't seem to work  (Read 257 times)

scriber

  • Newbie
  • *
  • Posts: 22
  • Karma: 0
  • Scribus User
Hyphenation in 1.5.4 doesn't seem to work
« on: July 18, 2019, 01:10:27 am »
Hi all,
I'm using scribus 1.5.4 on slackware linux 14.2_64bit, compiled from sources with a slackbuild (thanks to giorgio peron: https://github.com/gperon/mmyy_slackbuilds/tree/master/office/scribus).
I'm working on a document and I can't apply hyphenation to a frame with text arranged jiustified.
I set:
- document (and also at "preferences" level) language "Italiano",
- hyphenation "automatic during typing"

Then with the target text frame selected, I press "utilities">"hyphenated text" (I'm traslating my italian interface: utilità > testo sillabato).
But nothing changes: justified text rest without any hyphentaion "-" symbols, and spacing doesn't appear good.

I also check dictionarie files in "/usr/share/scribus/"
Code: [Select]
# ls -l /usr/share/scribus/dicts/hyph/hyph_it.dic
-rw-r--r-- 1 root root 1405 mar 12  2007 /usr/share/scribus/dicts/hyph/hyph_it.dic

# file /usr/share/scribus/dicts/hyph/hyph_it.dic
/usr/share/scribus/dicts/hyph/hyph_it.dic: troff or preprocessor input, ASCII text

# head /usr/share/scribus/dicts/hyph/hyph_it.dic
ISO8859-1
.a3p2n
.anti1
.anti3m2n
.bio1
.c2
.ca4p3s
.circu2m1
.d2
.di2s3cine
So, an Italian dictionary seems actually in place...

Could you help me to figure out why it doesn't work?
Any workoround to solve... and so on?

Thanks in advance!
Bye!  :)
« Last Edit: July 18, 2019, 02:06:13 am by scriber »

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1985
  • Karma: 26
    • the graphics lab
Re: Hyphenation in 1.5.4 doesn't seem to work
« Reply #1 on: July 18, 2019, 09:16:36 am »
ciao scriber

in the newer 1.5 releases you also (or only?) need to set the language in the the text properties panel...

ciao
a.l.e

scriber

  • Newbie
  • *
  • Posts: 22
  • Karma: 0
  • Scribus User
Re: Hyphenation in 1.5.4 doesn't seem to work
« Reply #2 on: July 18, 2019, 03:03:00 pm »
Grazie mille!
Solved: language in the text properties panel wasn't set to "Italiano".
So, by selecting target text frame, setting italian lang in properties panel and then press hypenate from utilities menu did the trick.
Documentation for 1.5.x dev version is not so clear, or may be I missed the above config procedure to activate hyphenation.

PS.
Just out of curiosity, when will the next stable version based on 1.5.x tree be released?

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1985
  • Karma: 26
    • the graphics lab
Re: Hyphenation in 1.5.4 doesn't seem to work
« Reply #3 on: July 18, 2019, 04:57:09 pm »
1.6 has been promised for the end of 2019...

scriber

  • Newbie
  • *
  • Posts: 22
  • Karma: 0
  • Scribus User
Re: Hyphenation in 1.5.4 doesn't seem to work
« Reply #4 on: July 18, 2019, 06:36:41 pm »
Ok, thanks a lot again!

As regards hyphenation, I found also a manual way to refine a justified text:
- put cursor wher you want to break a word
- press combination  "ctrl shift -" (insert > character > "optional or soft" hyphen)

When some line of justified text, after automatic hyphenation appears still too "over-spaced", here we can hyphenate by hands using the above procedure.

Bye!

 

palmate