Author Topic: Document opens , but does not appear... OSX 10.14.4  (Read 600 times)

StainlessB

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Document opens , but does not appear... OSX 10.14.4
« on: May 19, 2019, 02:16:46 am »
I worked on a document today and closed Scribus, afterwhich I promptly noticed an error. Upon re- opening Scribus --> to document... nothing

I right clicked on the Scribus Icon, ---> All Windows and the document shows up, but on my second monitor i get a small text box with "No Windows Available". as soon as I click on the document it disappears.

Tryed start a new document, same results.

Looking for potential fixes, I find several , however the file to edit is no where to be found in Preferences (I am the only user) and every effort to "show hidden" still doesn't lead me to a Scribus file

I-Mac Retina 5, 24 GB, dual monitors, 10.14.4

any ideas how to find the elusive file that has the (I believe) incorrect coordinates for the display? (seems to disapper screen right

Thanks

S


StainlessB

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Re: Document opens , but does not appear... OSX 10.14.4
« Reply #1 on: May 19, 2019, 02:42:53 am »
Update- finally found the file!  and following the code change, I'm back up and running!

It still opens  half off the screen, but I can at leats pull it into the monitor.

I made some changes as the initial window was much wider than  the moitor and most of it was just an empty white field

here is what I changed  the line to

<MAINWINDOW WIDTH="1300" MAXIMIZED="0" HEIGHT="794" YPOS="89" XPOS="1000"/>

Can anyone advise how to move it to the "left"?  I tried smaller numbers for the 1300 and the 1000 but this seemed to at least be workable
Does anyone know what causes this?


Just curious if it was operator induced

Thanks
« Last Edit: May 19, 2019, 03:11:19 am by StainlessB »

StainlessB

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Re: Document opens , but does not appear... OSX 10.14.4
« Reply #2 on: May 19, 2019, 06:11:32 am »
i've noticed something ...interesting

everytime I open/close the filewhich needed editting changes...

now I have this....

<MAINWINDOW WIDTH="1018" MAXIMIZED="0" HEIGHT="900" YPOS="106" XPOS="1704"/>

whereas, this is what I edited previously

<MAINWINDOW WIDTH="1300" MAXIMIZED="0" HEIGHT="794" YPOS="89" XPOS="1000"/>

something is going on

StainlessB

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Re: Document opens , but does not appear... OSX 10.14.4
« Reply #3 on: May 21, 2019, 05:50:58 am »
bump- once again x coordinates changed themselves so nothing shows on monitor screen. i corrected, back up and running

but does anybody know why this happens?  I can relaunch program 3-4 time before it's off screen???

Thanks much

Stainless

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1996
  • Karma: 26
    • the graphics lab
Re: Document opens , but does not appear... OSX 10.14.4
« Reply #4 on: May 21, 2019, 11:55:37 am »
i guess that you have the latest version of scribus (stable / development)...
if not, you should probably update and see if the issue has been fixed.

i've seen similar reports in the past... but i cannot tell if this specific issue has been solved or not.

personally, i don't have a mac nor a dual monitor setup... and i cannot try out...

but your analysis seems interesting to me...

if it happens with the development version, i think it's wort to fill a ticket on

https://bugs.scribus.net

if you don't have yet the development version 1.5, can you try to download it from the scribus website.

StainlessB

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Re: Document opens , but does not appear... OSX 10.14.4
« Reply #5 on: May 22, 2019, 04:33:08 am »
OK, just updatred to 1.5.4  I'll work with it tonight/tomorrow and see if th eproblem persists... fisrt I have re-familiarize myself as there are some differences between 1.4 and 1.5

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1996
  • Karma: 26
    • the graphics lab
Re: Document opens , but does not appear... OSX 10.14.4
« Reply #6 on: May 22, 2019, 11:20:19 am »
just a short important note: start using 1.5 for testing purposes only and only work on copies of your documents...

if you save a file with 1.5 you won't be able to open it with 1.4 anymore!

StainlessB

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Re: Document opens , but does not appear... OSX 10.14.4
« Reply #7 on: May 22, 2019, 04:43:34 pm »
same results, with each opening of Scribus, doucument moves off to the right (x increases)

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1996
  • Karma: 26
    • the graphics lab
Re: Document opens , but does not appear... OSX 10.14.4
« Reply #8 on: May 22, 2019, 08:55:07 pm »
then, can you please submit your analysis to https://bugs.scribus.net ?