Author Topic: Problem with symbol fonts  (Read 284 times)

Anna

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Problem with symbol fonts
« on: May 09, 2019, 09:03:37 am »
Please forgive me if I missed this topic anywhere in this forum, but I have unsuccessfully been trying to find a solution here and on other websites during the past few days. My problem: Scribus does not accept/recognize symbol fonts such as Webdings, Wingdings or Dingbats; it only shows red squares/rectangles instead of the symbols. The fonts work flawlessly in all other applications. The oft recommended "additional paths" option in settings does not do the trick (which seems logical since the respective fonts are in the same folder as the ones that do work.) After failing to solve the problem on Linux Mint I installed Scribus on Fedora, Ubuntu (both in Virtualbox) and Windows 10: The problem occurs on all operating systems. (Which is why I suspect that - given the problem's likely spread - I must have missed the somewhere in this forum.) Ideas anyone?

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1924
  • Karma: 26
    • the graphics lab
Re: Problem with symbol fonts
« Reply #1 on: May 09, 2019, 10:33:46 am »
webdings, windgdings and dingbats are not good fonts for print.

personally, i only have dingbats and it does work on a linux install.

if i insert them through the "insert > glyph" dialog i can pick them, insert them and i see then the glyphs in the text frame...

question: do you see the fonts listed in "file > preferences > fonts"?

Anna

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: Problem with symbol fonts
« Reply #2 on: May 09, 2019, 07:02:50 pm »
Wow, thank you! I would have never figured that out. (And yes, all the fonts can be found in file>prefs>fonts.) Does not seem to make sense that I cannot use the symbol fonts just like any other font, but using the glyph via insert>glyph is a workaround I can live with. Again: Thank you!  :)

 

palmate