Scribusoid

Author Topic: Changing file path loses inserted graphics  (Read 413 times)

Little_Evenstar

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Changing file path loses inserted graphics
« on: April 25, 2019, 12:55:06 pm »
Hello,

I'm experiencing a problem if I move a Scribus SLA file to a different folder, or if I move the source PNG or PDF graphics to a different folder. The inserted graphics are then 'lost' in the SLA file and the image frames are blank with a red cross (but they do have the image file name listed). If this happens all of the graphics need to be re-inserted.

I've tried to lock the images (CTR L), but it still happens.

Any suggestions, please?

Thanks.

RodneyLee

  • Jr. Member
  • **
  • Posts: 98
  • Karma: 1
  • Scribus User
Re: Changing file path loses inserted graphics
« Reply #1 on: April 25, 2019, 02:39:35 pm »
Next time use "Collect for Output" and move everything together, images are not embedded, this is a common mistake made by most user at one time or another

Little_Evenstar

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Changing file path loses inserted graphics
« Reply #2 on: April 25, 2019, 03:45:31 pm »

Many thanks, Rodney.

That's helpful.

Regards.

Nermander

  • Hero Member
  • *****
  • Posts: 1274
  • Karma: 17
Re: Changing file path loses inserted graphics
« Reply #3 on: April 27, 2019, 08:11:29 am »
The topic shows the misunderstanding.

It should be "Changing file path loses linked graphics"

Scrbius does not embed graphics in the SLA but includes a link to it. Moving the SLA (or the graphic) means the link is no longer correct.

 

palmate