Scribusoid

Author Topic: Error message in Preflight Verifier - what does this mean  (Read 382 times)

GregM

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Error message in Preflight Verifier - what does this mean
« on: January 11, 2019, 09:30:56 pm »
When I export to PDF in the Preflight Verifier everything has green checks except:

Layers
   Layer "Background - body text" Issue(s):  1
          Transparency used

I have no idea what that means. Is it a problem to printing this out from my PDF?

Nermander

  • Hero Member
  • *****
  • Posts: 1267
  • Karma: 17
Re: Error message in Preflight Verifier - what does this mean
« Reply #1 on: January 11, 2019, 10:23:17 pm »
PDF versions lower than 1.5 (I think) cannot handle transparency.

Whether this is a problem or not depends on how your are using it, but in most cases it means that transparent or semitransparent objects become solid color.

utnik

  • Hero Member
  • *****
  • Posts: 1268
  • Karma: 14
Re: Error message in Preflight Verifier - what does this mean
« Reply #2 on: January 12, 2019, 09:54:07 am »
PDF versions lower than 1.5 (I think) cannot handle transparency.

it's just .pdf 1.3 (and the 1.3 based versions x-1a and x-3).
.pdf 1.4 and above can handle transparencies.

utnik

GregM

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Re: Error message in Preflight Verifier - what does this mean
« Reply #3 on: January 14, 2019, 06:04:56 pm »
Thanks for the info.

So the way I now understand this, the SCRIBUS version I am working with is warning me that earlier versions of PDF will not support the transparency.

I am using the latest PDF versions so this should not be a problem. However this does give me a heads up that I ought to send a trial file to my printer before I continue to crank out these PDFs in case I'd have to tweak something.

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1854
  • Karma: 26
    • the graphics lab
Re: Error message in Preflight Verifier - what does this mean
« Reply #4 on: January 14, 2019, 07:10:02 pm »
no, greg, this is not the way pdf versioning works.

at least not in a linear way.

different pdf versions support different features.

but, it's true, in the same family of versions, higher numbers mean that all of the lower version features are supported and some more on top of it.

you should really make sure that you pick the version your print shop is asking for and that you stick to the features that the given version supports.

and be warned, that sometimes print shops have the bad habit of asking for a given version and add further restrictions.
(most of the time, until you're 100% sure that your printshop will manage correctly the transparencies don't use them (or use them in an almost visible place for testing them : - ))

Nermander

  • Hero Member
  • *****
  • Posts: 1267
  • Karma: 17
Re: Error message in Preflight Verifier - what does this mean
« Reply #5 on: January 15, 2019, 05:54:23 pm »
I am using the latest PDF versions so this should not be a problem.

Have you made sure the pre-flight verifier is set to the same PDF version that you intend to create?

I think (I don't have Scribus on this computer) you can set the pre-flight verifier to a completely different version than you are creating, which means it will give you warnings that are not relevant.
« Last Edit: January 15, 2019, 05:56:33 pm by Nermander »

 

palmate