Author Topic: Compatibility  (Read 75 times)

mnawij

  • Full Member
  • ***
  • Posts: 216
  • Karma: 2
  • Scribus User
Compatibility
« on: December 06, 2018, 06:44:52 am »
Hi Everyone! Are there any backwards compatibility issues with Scribus files generated in 1.5.4 back to 1.5.3? Is it just major dot release or minor dot releases for compatibility?

Thanks!

mnawij

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1647
  • Karma: 24
    • the graphics lab
Re: Compatibility
« Reply #1 on: December 06, 2018, 09:25:17 am »
hi mnawij,

the  rule is:

- there is no guarantee of compatibility between development releases. it's unlikely that files will become unreadable (and i don't think it has ever happened) but there might be glitches (different end of lines, slightly different position of items, ...)
- the team tries hard to ensure forward compatibility between stable releases (but at this point it's still unclear if this will be possible for the 1.4 to 1.6 migration: the new text engine is making that harder!)

now, to your question: i'm not aware of any important incompatibility between 1.5.3 and 1.5.4 (in both directions...)... do you have any evidence of something happening?

the release notes do not seem to suggest any breakage: https://www.scribus.net/scribus-1-4-7-and-1-5-4-released/

(on the other side, 1.5.3 is the first release with the new text engine, so you have to expect changes when exchanging files with 1.5.2 and 1.5.1)

mnawij

  • Full Member
  • ***
  • Posts: 216
  • Karma: 2
  • Scribus User
Re: Compatibility
« Reply #2 on: December 06, 2018, 10:34:27 pm »
Thanks a.l.e., no it is just that I have 1.5.4 and a friend I am working on for a monthly newsletter can only run 1.5.3 since their computer (mac) operating system is 10.9.5, just curious if I would run into any issues!

mnawij

 

palmate