Scribusoid

Author Topic: Hide Scroll Bars  (Read 412 times)

Milliways

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Hide Scroll Bars
« on: November 14, 2018, 07:38:21 am »
I installed Scribus 1.5.4 on my iMac running 10.13.6 and am working through the tutorials.

There are a couple of things I find difficult.

When I try to scroll my document using my Magic Mouse I find it wildly moving from side to side.

Is there ANY way to hide the horizontal scroll bar?

I also find the Help text inconveniently small, but none of the usual tools seems to change this.

Help System states
"For the 1.5/1.6 series, the online manual now uses a CSS file to control and enhance the appearance of the text. The file is called manual.css, and like many aspects of Scribus can be modified to your liking."

But I cannot find this.

I have also found that "Scribus now follows the XDG standard for configuration files. Therefore, the Scribus preference directory has moved from ~/.scribus/ to a new default location: ~/.config/scribus/."  is inaccurate and files are in ~/Library/Preferences/Scribus


a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1761
  • Karma: 26
    • the graphics lab
Re: Hide Scroll Bars
« Reply #1 on: November 14, 2018, 11:54:44 am »
hi

can you explain what is your issue with the horizontal scroll bar?

if there is a bug affecting the magic mouse, it might be worth to report it to https://bugs.scribus.net

for the help text: which help? the one showing up with F1?
i just tried and i could zoom it with scroll-mouse-wheel (as you can commonly zoom in most application... on mac it could be cmd-mouse-wheel...  with a magic mouse you might be able to pinch or move three fingers... it's a kind of magic... but it must be possible).

... i would not really go and change the css file...

and, finally, the XDG standard is for linux.
on mac scribus follows the MacOS standard... and on windows the windows standard...

... and you're welcome to share which tutorials you did like : - )

Milliways

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: Hide Scroll Bars
« Reply #2 on: November 20, 2018, 02:09:44 am »
hi

can you explain what is your issue with the horizontal scroll bar?

if there is a bug affecting the magic mouse, it might be worth to report it to https://bugs.scribus.net


The Magic Mouse acts like a normal optical mouse when moved, the surface acts like a trackpad - moving a finger up/down scrolls vertically, from side to side horizontally.

The issue I have is that attempting to scroll vertically (by a short distance) results in wild side-to-side movement. This is probably due to my slight deviation from straight up/down movement.

I don't want any horizontal scrolling, let alone the excessive response. In most applications I disable horizontal scroll - the monitor is so wide it serves no useful purpose, and I normally work on portrait mode. I need to expand text slightly (due to poor eyesight) and am quite happy to scroll vertically when needed.

The issue may be a mouse issue with Scribus, as I find the same thing happens in the file open menu etc.


for the help text: which help? the one showing up with F1?
i just tried and i could zoom it with scroll-mouse-wheel (as you can commonly zoom in most application... on mac it could be cmd-mouse-wheel...  with a magic mouse you might be able to pinch or move three fingers... it's a kind of magic... but it must be possible).

Yes - from Help Menu or F1

The normal Apple Zoom is ⌘+/⌘- - which does not work in Scribus. There are no options for gestures, but I just tried ⌘ plus scroll which does, although ideally I would like to set a larger default font (which I do in most applications)
« Last Edit: November 20, 2018, 02:33:40 am by Milliways »

 

palmate