Author Topic: characters squashed on first line of second frame  (Read 2928 times)

DrMartinus

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
characters squashed on first line of second frame
« on: November 21, 2011, 10:30:13 am »
Hi,

I use scribus-ng and have been using scribus for many years. Always there were some issues, but most I could handle myself. This time I'm stuck:

I have a text in Times Roman that crosses two text frames. The frame break is in the middle of a list, for which I use a style that sets a tab etc. The line on the top of the second frame is squashed or squeezed together on both sides, see the screenshot:


Actually, it should state in that top line: "22. Mai       5. Gebot" similar to the lines below, but it doesn't seem to respect the numbers, and the word "Gebot" is also moved further to the right than the others. When I decrease or increase the length of the frames, the problem remains: whatever is in the first row of the second frame, gets squashed in this manner. As soon as the text flows normally, everything is fine.
I checked the width of the frames, they are identical as they should. Somehow the tab is forgotten in the first line, and more. When I export the file to pdf, this distortion is also exported.
I didn't have this problem before, even though I had similar situations.

I use Linux Mint 11 with Gnome as desktop and keep it up-to-date. QT 4.7.2 as per the info from Scribus. 64 bit. What else is required?

« Last Edit: November 21, 2011, 10:31:45 am by DrMartinus »
Using Linux Mint 11 with Gnome, 64 bit, Scribus-ng (1.4.0.rc6)

Meho R.

  • Full Member
  • ***
  • Posts: 198
  • Karma: 0
Re: characters squashed on first line of second frame
« Reply #1 on: November 21, 2011, 02:04:17 pm »
Interesting. Can you, please, attach an example .sla file which shows the issue, for testing purposes?

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2052
  • Karma: 27
    • the graphics lab
Re: characters squashed on first line of second frame
« Reply #2 on: November 21, 2011, 02:23:07 pm »
please to adjust the first line height to something else...

it's a bug, that's for sure (at least if you didn't do anything funky we don't know about), but setting the height of the first line to "height of the line" (or similar: i don't have a scribus open atm) should be a workaround to your issue.

ciao
a.l.e

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2052
  • Karma: 27
    • the graphics lab
Re: characters squashed on first line of second frame
« Reply #3 on: November 21, 2011, 02:24:04 pm »
p.s.: if it's indeed a bug, please post it to bugs.scribus.net ! a.l.e

DrMartinus

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Re: characters squashed on first line of second frame
« Reply #4 on: November 23, 2011, 06:29:29 pm »
I apologise for replying so late. I had to finish the project, and had also other work to do.
I herewith attach a sample of the problem. I just copied the two text frames and put them in an new page. I hope everything you need is in there. Let me know what to do from here.

I found another textbox where the text was scrambled up in a similar way. Decreasing the font size helped. But in earlier documents, this was never a problem (the last of this kind with the same text was done in September. I don't know if rc6 was already out then, if so, I probably used that already then).
Using Linux Mint 11 with Gnome, 64 bit, Scribus-ng (1.4.0.rc6)

Meho R.

  • Full Member
  • ***
  • Posts: 198
  • Karma: 0
Re: characters squashed on first line of second frame
« Reply #5 on: November 26, 2011, 03:40:58 pm »
This looks like a bug, so you might consider filing a bug report.

However, for now, as a.l.e pointed out, if you select a text frame, then go to Properties Palette > Text > First Line Offset and change "Maximum Ascent" to either "Font Ascent" or "Line Spacing", the issue should disappear.

 

palmate