Author Topic: Failed to embed the PDF file  (Read 272 times)

ajytojen

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Failed to embed the PDF file
« on: May 20, 2018, 07:20:12 pm »
Hi all,

When exporting a project containing a PDF inserted in a Image Frame as PDF with the option "Embed PDF & EPF files (EXPERIMENTAL)" enabled, the resulting file has a rasterized version of the PDF.

During the export, scribus outputs: "Failed to embed the PDF file" in the console. I have scribus 1.4.7 on arch linux.

I tried with several pdfs (I attached a test pdf and the resulting export) and the problem persists.
I also tried to export the project on a different machine (Linux Mint) with scribus 1.4.6 and it works fine...

Any ideas of what could be the problem and how I could debug it?

Thanks

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1532
  • Karma: 23
    • the graphics lab
Re: Failed to embed the PDF file
« Reply #1 on: May 21, 2018, 11:25:37 am »
1.5.x can correctly include your pdf.
so the pdf is correct and scribus can use it.

did you read the tooltip attached to the "embed" option?
do you fulfill all the conditions?

i don't know the details about the embedding of pdf, but i could imaging it's done with podofo... is podofo installed on your system?

ajytojen

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: Failed to embed the PDF file
« Reply #2 on: May 21, 2018, 04:39:36 pm »
Thanks for your reply.

I compiled the latest version from svn (1.5.5 r22550). I can import the pdfs as vector files and it works, although for some pdfs the text is missing...

If I try to embed the pdfs as previously, it still fails. However, there is more debugging output in the terminal and it seems that the problem is indeed linked to podofo:

Code: [Select]
embed list: ""
subset list: ""
outline list: ""
PoDoFo error, falling back to raster!


PoDoFo encountered an error. Error: 19 ePdfError_InvalidDataType
        Callstack:
        #0 Error Source: /build/podofo/src/podofo-0.9.5/src/base/PdfParser.cpp:233
                Information: Unable to load objects from file.
        #1 Error Source: /build/podofo/src/podofo-0.9.5/src/base/PdfParser.cpp:285
                Information: Unable to find trailer in file.
        #2 Error Source: /build/podofo/src/podofo-0.9.5/src/base/PdfParser.cpp:614
                Information: The trailer was found in the file, but contains errors.
        #3 Error Source: /usr/include/podofo/base/PdfVariant.h:641


Failed to embed the PDF file
PoDoFo error while reading page count!


PoDoFo encountered an error. Error: 19 ePdfError_InvalidDataType
        Callstack:
        #0 Error Source: /build/podofo/src/podofo-0.9.5/src/base/PdfParser.cpp:233
                Information: Unable to load objects from file.
        #1 Error Source: /build/podofo/src/podofo-0.9.5/src/base/PdfParser.cpp:285
                Information: Unable to find trailer in file.
        #2 Error Source: /build/podofo/src/podofo-0.9.5/src/base/PdfParser.cpp:614
                Information: The trailer was found in the file, but contains errors.
        #3 Error Source: /usr/include/podofo/base/PdfVariant.h:641


I have podofo 0.9.5-2 installed and it seems to be working fine. If I try `podofopdfinfo test.pdf` with the file that I embedded, no problem is detected (correct page count as well):

Code: [Select]
podofopdfinfo test.pdf
Document Info
-------------
        File: test.pdf
        PDF Version: 1.5
        Page Count: 1
        Page Size: 317.842 x 463.392 pts

        Fast Web View Enabled: No
        Tagged: No
        Encrypted: No
        Printing Allowed: Yes
        Modification Allowed: Yes
        Copy&Paste Allowed: Yes
        Add/Modify Annotations Allowed: Yes
        Fill&Sign Allowed: Yes
        Accessibility Allowed: Yes
        Document Assembly Allowed: Yes
        High Quality Print Allowed: Yes

Classic Metadata
----------------
        Author:
        Creator:
        Subject:
        Title:
        Keywords:
        Trapped:

Page Info
---------
Page Count: 1
Page 0:
->Internal Number:1
->Object Number:2 0 R
        MediaBox: [ 0.000000 0.000000 317.841644 463.391571 ]
        Rotation: 0
        # of Annotations: 0
Outlines
--------
        None Found
Names
-----
                None Found

I reported this problem in the bug tracker, but I was told that there is nothing they can do...

Quote
did you read the tooltip attached to the "embed" option?
do you fulfill all the conditions?
It just says that this will not take into account the colorspace of the pdfs, but I didn't enable color management anyway.