Author Topic: Can't set my language as default in spell check.  (Read 340 times)

loggerjack

  • Newbie
  • *
  • Posts: 8
  • Karma: 1
  • Scribus User
Can't set my language as default in spell check.
« on: April 26, 2018, 01:32:24 pm »
Using Scribus Version 1.4.6 on Linux 18.3


Hi, Can someone help me with spell-checking please. I've never been able to get it to work. In story editor, I select my language, English (UK), but it doesn't do anything. So after googling problem, I try this:

file>preferences>Hyphenation and Spelling>Spelling Tab ...

... and in the left column I see "English (UK)" listed under "Installed Dictionaries"

Then I go to edit > styles > ... I select my paragraph style ... > edit > character style tab > ... Language drop down

... but English (UK) isn't an option. There are other languages in the dropdown, like English (Canadian), English (USA), French, etc, which were also listed as installed dictionaries, but no Rnglish (UK)

Any suggestions?

loggerjack

  • Newbie
  • *
  • Posts: 8
  • Karma: 1
  • Scribus User
Re: Can't set my language as default in spell check.
« Reply #1 on: April 26, 2018, 07:52:33 pm »
OK, replying to my own question, I've realised that  ...

(a) I don't need to go into text editor to spell check, I can just click on the text frame within the main window then go to item>check spelling
(b) Method (a) is convenient and it works, therefore I no longer care why spell check doesn't work within text editor
(c) The reason I can't choose English (UK) in style editor is because it has already been set as my default language.

OK, so I'm a duffus. My only slight excuse is that I've been using Scribus for about 12 years (love it, thanks to everybody who has worked so hard to make it so great) and a lot of menus and settings have changed since I last tried to sort out the spell check.

I'll get my coat ........

 

palmate