Author Topic: why do my images disappear - and why are .sla files so small? (related, maybe?)  (Read 3304 times)

catteau

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
  • Scribus User
I'm creating a magazine - 24 pages total, with a fair number of images. 

I'll be working along, inserting images, saving my file very regularly.  And then suddenly some images will be gone, and in the frame where they were is the filename instead of the image.  If I save the Scribus file to a new name and reopen the previously saved version, the images are gone there, too.  Since it gives me the filenames, they are easy to reload - and when I do that, they are already scaled and sized correctly, I don't need to "adjust image to frame." 

If I try to export to a pdf from the file with missing images, it tells me they are missing - so they are really not there, it's not as if I somehow made them invisible.  Not all images in the file disappear, just a few will disappear (different ones at different times, though).

What is going on here?

I also noticed that my .sla file is around 340K, with around 13 pages completed.  When I save it to .pdf, that file is 27 megs.

So does Scribus actually only save pointers to images, not integrating the image into the file itself?  That would explain why the file is so small.  But if that is the case, it would suggest that if I move or rename an underlying image file - or delete it - my Scribus document will no longer be able to find it.

Why would my images suddenly disappear when I wasn't even working on them?  Sometimes it is images from a previous page that I haven't touched in hours. 

I'm using Scribus 1.4.6 on OSX, and this is my first time using the software, so I have lots to learn.

Thanks for any enlightenment anyone can provide!



Joy

catteau

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
  • Scribus User
A bit more info - I took some screenshots to show what's happening.  Just came back to my (saved) file after doing something else for a few minutes, found around a dozen images had disappeared.  A couple of images attached to show what I'm seeing when the images are gone.

I put them all back in, saved the file again.  But I'm sure they will keep disappearing.  Why???????

GarryP

  • Hero Member
  • *****
  • Posts: 1600
  • Karma: 25
  • Scribus User
You hit the nail on the head in your first post Joy.
Scribus uses a relative path from the document to the image, rather than including the image in the SLA.
This is useful as it not only keeps the SLA size to a minimum but it also means that you can update the image outside of Scribus - which means that Scribus doesn't need to have lots of image manipulation tools in it.

Images "disappearing" from image frames usually happens when someone either moves/renames/deletes the image file or moves the SLA.
If you have not moved/deleted/renamed anything and images are still disappearing, that sounds unusual.

Are your images and SLA on the same physical hard drive?
Do you have any kind of "file/media management" software running that could be re-organising your files in the background?

When you save your SLA and come back to it, or a new version of it, what's the exact process you are using? I've a feeling that that's where the problem is but I would need to know precisely what you're doing.

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2354
  • Karma: 33
    • the graphics lab
hi catteau

in my experience, when people have images disappearing there are two causes:

- they don't have enough memory at disposal
- they're doing something "silly".

what you already have discovered: after having loaded an image into a scribus image frame, you're not supposed to move it or rename it.
nor move the .sla file. (but you can just rename it).

summarized: if you have not done anything in between, it's probably a memory issues... but people have very different definitions for "have done nothing"...

LesCM19

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 1
  • Scribus User
if you have a root folder you are saving sla files to and storing images, the whole lot can be moved without losing the path to the images.
cheers

Les

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2354
  • Karma: 33
    • the graphics lab
les hint can work but does not have to.

the only secure way for moving around a scribus project is by using the "file > collect for output" tool.

... say a guy who just got a booklet back from the print shop where all images are missing...

catteau

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
  • Scribus User
Re: why do my images disappear??????????????
« Reply #6 on: May 11, 2020, 03:11:46 am »
I am working once again on the same magazine that I lay out twice a year, and had the exact same thing happen - only this time every single photo in the entire thing has disappeared.

I did a google search for "why do Scribus photos disappear" and realized I had asked the same question two years ago.

EEEEEEKKK!!!!!

I have NOT moved my photos or my files.  I have saved the file.  I was working on it earlier today, saved it, left the file open (rather than closing Scribus) and came back to the exact same thing a few hours later.  Except now every single photo is gone, dozens of them.  I saved the file with a new name, opened the version that I had saved earlier today, and there are no photos. 

WHY????????????  Is this a bug?  Should I give up and stop using freeware, maybe commercial software doesn't do this?  It's crazy!!!!!

Surely I'm not the only person to whom this happens?


dragonfly

  • Full Member
  • ***
  • Posts: 158
  • Karma: 0
  • Scribus User
I have been away from forum for many moons but just returned to browse latest news.
Reading this thread perhaps the images "disappear" (do not load) if they do not have the same permissions as Scribus host *.sla?  Are the photos on a separate device perhaps no longer mounted? i don't know what OS you use but I would scan your filesystem to try to locate just one of your lost images. Then take it from there. Of course the mantra is ... always keep a backup.




catteau

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
  • Scribus User
LOL, I just returned too, yesterday, to post the same question I'd posted two years ago.  The images show in the .sla file, are saved, show again when the file is reopened, then at some point disappear.  I have not moved the images, I have not moved the .sla file.  It's easy to locate the missing files and reinsert them - they are right were they were all along, from when I first inserted them in the file.

i also found most of them when I opened the autosave version of the file, except for the most recent ones.  Interesting.

I now think that this problem has to do with leaving the file saved but open in Scribus, instead of saving and then closing Scribus any time I might step away from my computer.  If I make sure the file is saved with the photos, then close Scribus, and then reopen the file later, the images don't seem to disappear.  But if I save the file and close my computer, or let it "go to sleep," without closing Scribus, then sometimes the images do disappear and I have to reload them. 

I can't imagine this is not a bug in Scribus, and I also can't imagine I'm the only person who has ever had this problem.

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2354
  • Karma: 33
    • the graphics lab
i don't recall having ever seen a case where images were disappearing because of a scribus bug.

most of the time, the user has moved the .sla file or the images.

in some case the issue is with the memory available.

if the images disappear while you're working on the document, i would suggest that scribus is hitting a memory  limit.
the way to check that is by collecting the document for output and check it on a computer with more memory available.

catteau

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
  • Scribus User
What do you mean by "collecting the document for output?"  When this magazine is ready to print I convert it to a pdf and it goes to the printer.  Is that what you are referring to, or something else?

I don't have access to another computer, so I can't actually test it, but maybe it is a memory problem.  I just tried converting the current draft to pdf and it's around 90 megs.  And the last time I was posting these messages I was working with a bigger file - issues in between, where I don't seem to have had the problem, were smaller.  I've never had memory problems with anything else, but then usually I'm not working with files that size. 

Maybe I'll try playing around with a small test file, and see whether it seems consistent that leaving the file saved but open is associated with images disappearing.  Later, once this issue is done!  ;-)  (Or else I'll forget and six months from now I'll be posting these messages again...)

Thank you!

dragonfly

  • Full Member
  • ***
  • Posts: 158
  • Karma: 0
  • Scribus User
I have no experience in OSX but from a quick search it seems that there can be other scenarios where files mysteriously disappear. Here is just the first search ..https://discussions.apple.com/thread/7900918.  I am sure other scenarios (unrelated to Scribus) can be searched.

RodneyLee

  • Full Member
  • ***
  • Posts: 211
  • Karma: 3
  • Scribus User
"Collect For Output" gathers all you file related to the current document and puts them in a single folder

catteau

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
  • Scribus User
dragonfly, my files aren't disappearing from my computer - they are disappearing from their place in the Scribus file.  They are all where I left them on my hard disk.  Which isn't to say that it's not an OSX issue, and my operating system isn't totally up to date, nor is my computer.  But I'm not losing anything off my hard disk.

AdmFubar

  • Newbie
  • *
  • Posts: 35
  • Karma: 0
  • Scribus User
How old is your computer? This could be a sign of failing hard drive. Is it just this one document you are working on? or are others affected?

 

palmate