Author Topic: Scribus 1.5.4 on Debian  (Read 1451 times)

clubex

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Scribus 1.5.4 on Debian
« on: March 06, 2018, 12:58:06 am »
Hi all

I am returning to Scribus after a few years doing something entirely different. Maybe I'm missing something very simple but where can I find a download for Scribus 1.5.4 for a Debian Linux OS other than Ubuntu? Many people seem to think that because Ubuntu is derived from Debian they are the same but there significant differences between them to make it unsuitable to install a Ubuntu app in Debian. Even their repositories are different.

Can anyone help me? Even a svn would do!


mnawij

  • Full Member
  • ***
  • Posts: 207
  • Karma: 2
  • Scribus User
Re: Scribus 1.5.4 on Debian
« Reply #1 on: March 06, 2018, 05:34:19 am »
Hi clubex, are you running Debian 9?  Also has anyone seen or heard if there is a flatpak yet for scribus?

Regards,

mnawij

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1477
  • Karma: 20
    • the graphics lab
Re: Scribus 1.5.4 on Debian
« Reply #2 on: March 06, 2018, 10:39:39 am »
currently, scribus 1.5.3 seems only to be in experimental and not in testing:

https://packages.debian.org/search?keywords=scribus

no idea why.

you can get the latest image from:

http://impagina.org/download/

if you're ready to copmile scribus (not a bad idea at all!) you can follow these instructions:

https://github.com/aoloe/scribus-manual-development/blob/master/content/getting-started/getting-started.md

it contains the links to

https://github.com/scribusproject/scribus

and

svn co svn://scribus.net/trunk/Scribus scribus

ah, yes, there is also a flatpak:

https://wiki.scribus.net/canvas/Flatpak

clubex

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Scribus 1.5.4 on Debian
« Reply #3 on: March 06, 2018, 02:18:37 pm »
mnawij:
I've been running Debian sid (unstable) since at least 2001. Contrary to what some people think Debian sid is not "unstable" in a bad sense it merely means the distro is constantly changing Sometimes it's difficult but I like bleeding edge stuff!

a.l.e:
Thanks. I'll have a look into your list later today. Hopefully I'll find a 1.5.4 somewhere amongst your list. That said I had hoped it would have been easier to find a 1.5.4 package for Debian than it has been.   

Yes I was aware Debian experimental was on 1.5.3. Scribus was always very late on Debian due I think to there being only one guy preparing the packages and then only when he/she has the time.

 

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1477
  • Karma: 20
    • the graphics lab
Re: Scribus 1.5.4 on Debian
« Reply #4 on: March 06, 2018, 02:54:53 pm »
- the appimages contain the latest code that has been (manually) synced on github (it's created through travis)
- the debian maintainer does a tremendous job and is very responsive. he packages everything that makes sense.
  but i have no idea why why scribus-ng is only available for experimental. it's probably related to some dependencies.
  if you want the latest code, he is also providing a ppa, which you should be able to get to work on debian, since he is using the very same packages.
  (https://launchpad.net/~scribus/+archive/ubuntu/ppa)

imo, on debian testing/unstable systems, if you're regularly using scribus, the best option is to compile it yourself.
otherwise, the appimage is not a bad option. (but scripting won't work)

mnawij

  • Full Member
  • ***
  • Posts: 207
  • Karma: 2
  • Scribus User
Re: Scribus 1.5.4 on Debian
« Reply #5 on: March 07, 2018, 12:19:59 am »
A.l.e., Thank you for the heads up on the Flatpak status.

clubex

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Scribus 1.5.4 on Debian
« Reply #6 on: March 07, 2018, 06:14:04 pm »
ale:
I'm sorry but none of this worked for me. There always seems to be a library missing or a wrong path for my distro. Plus the missing xcb plugin problem that seems to bedevil so may other applications on Debian and Ubuntu.

Trying to compile failed because of at least one library that isn't even in Debian's repositories. I could attempt to convert a  library package from another distro but I don't see why I should take such a drastic and risky step.

All the items quoted look to me to be packaged for Ubuntu which, as I said earlier, although derived from Debain and even uses the same packaging tools, is not Debian. Ubuntu ceased to be Debian many years ago.

I note that on both the Mattia Rizzolo's Ubuntu page (quoted by ale) and his Debian page, the latest version of Scribus is 1.5.3 and has been for some time.  Although I do not have the timerity to get in touch with Mattia on this issue I venture to suggest the reason is due to the library difficulties I mentioned above.

Anyway it looks as if the only development version of Scribus which is readily available for me (Debian) is 1.5.3 even if it's in experimental. I really wanted 1.5.4 but there it is.

ps I've just done an apt full-upgrade and noted a lot of upgraded libxcb packages in Debian sid. So I might give the whole thing another try tomorrow. Never say die.
 

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1477
  • Karma: 20
    • the graphics lab
Re: Scribus 1.5.4 on Debian
« Reply #7 on: March 07, 2018, 10:00:05 pm »
no idea.

i have debian testing and i can compile scribus without any issues...
(well, except OSG... afaik, it should not be installed or you shulld tell cmake to ignore it:  -DWANT_NOOSG=1)

the appimage also used to work here, but i have not tried for some time...
let me try it...
---> indeed it does not work here...

afaik, mattia is taking care of the debian package and he then only pushes the same packages into ubuntu.
but yes, he is mainly an ubuntu guy, afaik.

i don't know what libxcb but from what i could understand from a quick internet + apt search it does not relate to scribus.

i don't know which instructions you are folllowing, but if you can come in irc we can try to sort out the issues for compiling...
i'm mostly around at daytime CET.

clubex

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Scribus 1.5.4 on Debian
« Reply #8 on: March 08, 2018, 01:37:26 pm »
Perhaps I'm not explaining myself clearly (not unknown as my wife will attest).

1.5.3 is available in Debian and I have installed it and am using it.

I would like to try Scribus 1.5.4.

Perhaps I'm missing something simple but everywhere I've looked I cannot find a linux binary blob or the source code for Scribus 1.5.4. All I can find is Scribus 1.5.3. So 1.5.3 appears to me to be the latest version available for Debian (ditto for Ubuntu). 

So if anyone is actually running Scribus 1.5.4 on Debian and if you are, where did you get it and if you compiled it where can I get the source code for Scribus 1.5.4?.

a.l.e thank you for your help. I always enjoy your comments over in lists.scribus.net.
Regarding the libxcb libraries. as I understand it X, although graphically necessary for linux, is enormously complicated (perhaps detailed is a better word) so more and more developers are using (and creating) the libxcb libraries . There are lots of them and they are designed to allow easier access to X functions and also provide bindings between X functions and various coding languages. Trouble is if a developer writes one especially to make his/her life easier it may take some time to filter through to all distros.

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1477
  • Karma: 20
    • the graphics lab
Re: Scribus 1.5.4 on Debian
« Reply #9 on: March 08, 2018, 11:20:23 pm »
1.5.4 is not released and is not available in debian as a package.

normally, there is an appimage for the 1.5.4 snapshot, but -- indeed -- it does not work on my debian testing.

and 1.5.4 actually compiles without issues (except for OSG) on debian testing.

so, the best way to get 1.5.4 is to compile it from svn or git.

concrning X11: scribus goes through Qt5... i'm not aware of any direct dependency on X11...

 

palmate