Author Topic: How to prevent Scribus from embedding type 3 fonts in PDFs  (Read 5866 times)

Gecko

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
How to prevent Scribus from embedding type 3 fonts in PDFs
« on: August 21, 2013, 09:39:42 am »
Hi,

First of all: Hello to everybody on this forum!

I have looked for an answer to my problem but cannot find anything suitable.
I've been "messing around" with Scribus for a while now but only start getting into it over the last month or two; so apologies if my question has been answered before.

I'm trying to create a PDF document (one page) that is printer friendly, i.e. with CMYK colours and outlined fonts.
I got the CMYK colours thing working but I'm having issues with outlined fonts.

It seems that no matter how I tried, I cannot generate a PDF with outlined font in it (every time there is something embedded)
Even if I select «outline all fonts» when creating PDF, I still end-up with Type 3 fonts embedded in my PDF.
I tried to tick/untick every boxes under Document Setup -> Fonts (Embed in PS, subset, etc...) but no luck: I'm stuck with Type3 fonts in my PDF...

This is driving me nuts!

So: How do I prevent Scribus from embedding fonts in PDFs???




leaf

  • Jr. Member
  • **
  • Posts: 88
  • Karma: 0
  • Scribus User
Re: How to prevent Scribus from embedding type 3 fonts in PDFs
« Reply #1 on: August 21, 2013, 11:29:10 am »
Hi,

First of all: Hello to everybody on this forum!

I have looked for an answer to my problem but cannot find anything suitable.
I've been "messing around" with Scribus for a while now but only start getting into it over the last month or two; so apologies if my question has been answered before.

I'm trying to create a PDF document (one page) that is printer friendly, i.e. with CMYK colours and outlined fonts.
I got the CMYK colours thing working but I'm having issues with outlined fonts.

It seems that no matter how I tried, I cannot generate a PDF with outlined font in it (every time there is something embedded)
Even if I select «outline all fonts» when creating PDF, I still end-up with Type 3 fonts embedded in my PDF.
I tried to tick/untick every boxes under Document Setup -> Fonts (Embed in PS, subset, etc...) but no luck: I'm stuck with Type3 fonts in my PDF...

This is driving me nuts!

So: How do I prevent Scribus from embedding fonts in PDFs???

If You prepare file for print - print house, You need embed fonts, or need text in curves. For what fonts without embed status?
If You need text in curves will do inside Scribus (click text inside Scribus and convert to curves), not when export to pdf.

GarryP

  • Hero Member
  • *****
  • Posts: 1600
  • Karma: 25
  • Scribus User
Re: How to prevent Scribus from embedding type 3 fonts in PDFs
« Reply #2 on: August 21, 2013, 03:54:03 pm »
You might find this discussion interesting: http://forums.scribus.net/index.php/topic,815.0.html

Basically you need to make sure that you have no styles (or sub-styles) that are set to fonts you're not actually using and also that the default text frame font (in Document Setup / Tools) is one that you are using.

Once you've done that you should be able to outline all of your fonts and have none embedded. Fingers crossed!

P.S. I personally wouldn't recommend converting text to curves for large blocks of text, unless you really have to for some reason. Converting to curves stops you from editing the text as text. (However, it can be used in a handy way to keep the file size down by not embedding a whole font just for a single-use bit of text.)

P.P.S. You can also look at http://forums.scribus.net/index.php/topic,455.0.html which gives some extra information/links on embedding.

Gecko

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: How to prevent Scribus from embedding type 3 fonts in PDFs
« Reply #3 on: August 22, 2013, 03:03:55 am »
If You prepare file for print - print house, You need embed fonts, or need text in curves. For what fonts without embed status?
If You need text in curves will do inside Scribus (click text inside Scribus and convert to curves), not when export to pdf.
Yes leaf, the generated PDF will be used by a professional printer; that's why I do need all fonts to be outlined (not embedded).

So, if I'm following, I need to convert all fonts to outline PRIOR to export to PDF?
What's with the «Outline all fonts» option in PDF export then?

Also, how can I select all the text areas in the document and convert them to outlines in one (or a couple of) click(s)?
Or do I have to do one text area after next? (which doesn't seem efficient...)

You might find this discussion interesting: http://forums.scribus.net/index.php/topic,815.0.html

Basically you need to make sure that you have no styles (or sub-styles) that are set to fonts you're not actually using and also that the default text frame font (in Document Setup / Tools) is one that you are using.

Once you've done that you should be able to outline all of your fonts and have none embedded. Fingers crossed!
Thanks Garry, I did read this thread but my problem is the other way around.
I also did check that there are no font in the Document Setup that I don't use (I did have this issue before though...)
I thought too that with all correct boxes ticked I will end up with no font embedded, but nope...

In fact, the font embedded are not your normal Type1 (or OTF or TTF) font, but a Type3 font with a different name than the normal font name.
I have Fo0S0 and Fo1S0 font embedded (as Type3) in my document (instead of Avenir Light and Avenir Medium).
Unlike most other post in related thread my problem is that I don't want any font to be embedded.

I have yet to try with different fonts to see if I have the same issue.

When following leaf's advice (converting text to outline prior to export) I do end-up with a PDF with no font embedded...
But it's inefficient as I have to convert each text area individually

leaf

  • Jr. Member
  • **
  • Posts: 88
  • Karma: 0
  • Scribus User
Re: How to prevent Scribus from embedding type 3 fonts in PDFs
« Reply #4 on: August 22, 2013, 10:25:13 am »
Also, how can I select all the text areas in the document and convert them to outlines in one (or a couple of) click(s)?
Or do I have to do one text area after next? (which doesn't seem efficient...)

It is simple
1.Edit -> Advanced select all or (ctrl alt A)
2. on Curent Layer, and with atrributes and item type - text frame and ok (in one step You have select all text on all pages)
3 item -> convert to -> outlines

GarryP

  • Hero Member
  • *****
  • Posts: 1600
  • Karma: 25
  • Scribus User
Re: How to prevent Scribus from embedding type 3 fonts in PDFs
« Reply #5 on: August 22, 2013, 02:59:40 pm »
Gecko, here's a discussion about the Fo*SO type-3 fonts http://forums.scribus.net/index.php/topic,999.0.html that might be a useful read, or it may not. I don't know if it will help with your problem.

Esppee

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: How to prevent Scribus from embedding type 3 fonts in PDFs
« Reply #6 on: April 22, 2016, 06:35:35 pm »
Hi - I'm just wondering if this post was ever resolved?  I'm having the same issue - I don't want any Fo1S0, etc. to appear.  Or if they appear, I'm unable to embed them.  I need all fonts embedded (and searchable) when it's outputted as a PDF. So if they must remain (the Fo1S0 font series) they need to somehow be embedded.

 

palmate