Scribusoid

Author Topic: Help installing RC5 in Ubuntu  (Read 4374 times)

brohan

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
Help installing RC5 in Ubuntu
« on: August 31, 2011, 02:45:56 am »
I had been using Scribus on windoze 7, when it gave out. I fired up my Linux box, and am now trying to install RC5, as that is what I have on Windows 7. I hav downloaded and then untarred the bz2 file. When I run Cmake I get the error below. Any help is greatly appreciated.  According to Synaptic Package Manager I have libqtcore4.

Thank you in advance.

root@brohan-desktop:/usr/local/scribus-1.4.0.rc5# cmake /usr/local/scribus-1.4.0.rc5
-- The CXX compiler identification is unknown
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
-- Scribus 1.4.0.rc5 will be built to install into /usr/local
-- Machine: i486-linux-gnu, void pointer size: 4
-- Found target X86
-- Building for target i486-linux-gnu
-- Using standard ApplicationDataDir. You can change it with -DAPPLICATION_DATA_DIR
CMake Error at /usr/share/cmake-2.8/Modules/FindQt4.cmake:673 (MESSAGE):
  Could NOT find QtCore header
Call Stack (most recent call first):
  CMakeLists.txt:484 (FIND_PACKAGE)



brohan

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
Re: Help installing RC5 in Ubuntu
« Reply #1 on: August 31, 2011, 08:30:04 am »
I followed the instructions at http://wiki.scribus.net/canvas/Debian to add the deb http://debian.tagancha.org/debian/ natty main line in Synaptic Package Manager, then reloaded. I then added the key per the same webpage, ignoring the not secure part, then I tried to add the RC5 package that was now showing in the package manager and I received the following errors:

The following is unsecured etc, do you want to proceed
Not Authenticated:
libpodofo0.9.0

I then Mark this to proceed, an receive the following:


scribus-ng:
  Depends: libjpeg62 (>=6b1) but 6b-15ubuntu1 is to be installed
 Depends: libpython2.7 (>=2.7) but it is not installable
  Depends: libqtcore4 (>=4:4.7.0~beta1) but 4:4.6.2-0ubuntu5.2 is to be installed
  Depends: libstdc++6 (>=4.5) but 4.4.3-4ubuntu5 is to be installed



Any Suggestions?

brohan

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
Re: Help installing RC5 in Ubuntu
« Reply #2 on: August 31, 2011, 08:34:28 am »
I closed Synaptic, and restarted it. Now when trying to get the scribus-ng RC5~1 package, I do not get the unauthenticated warning, but it says it will install libpodofo0.9.0, when I select Mark, it then still gives the error messages as before:


cribus-ng:
  Depends: libjpeg62 (>=6b1) but 6b-15ubuntu1 is to be installed
 Depends: libpython2.7 (>=2.7) but it is not installable
  Depends: libqtcore4 (>=4:4.7.0~beta1) but 4:4.6.2-0ubuntu5.2 is to be installed
  Depends: libstdc++6 (>=4.5) but 4.4.3-4ubuntu5 is to be installed

John_Jason_Jordan

  • Jr. Member
  • **
  • Posts: 76
  • Karma: 4
Re: Help installing RC5 in Ubuntu
« Reply #3 on: August 31, 2011, 08:39:01 am »
scribus-ng:
  Depends: libjpeg62 (>=6b1) but 6b-15ubuntu1 is to be installed
 Depends: libpython2.7 (>=2.7) but it is not installable
  Depends: libqtcore4 (>=4:4.7.0~beta1) but 4:4.6.2-0ubuntu5.2 is to be installed
  Depends: libstdc++6 (>=4.5) but 4.4.3-4ubuntu5 is to be installed

When you have Synaptic open how many packages does it show as available in the bottom left corner of the window? If it is substantially less than 25-26,000 or so, then you probably don't have the Ubuntu repositories enabled where the above dependencies are located. If it does show 25-26,000 or so, then I'll shut up because there is something else wrong that I don't know how to fix.
Linguistics on Linux!

brohan

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
Re: Help installing RC5 in Ubuntu
« Reply #4 on: August 31, 2011, 08:49:15 am »
In Synaptic I show 30,621 packages listed, 1485 installed, 0 broken, 0 to install/upgrade.  python 2.7 is not listed as an available package, could this be the issue?
« Last Edit: August 31, 2011, 09:04:16 am by brohan »

John_Jason_Jordan

  • Jr. Member
  • **
  • Posts: 76
  • Karma: 4
Re: Help installing RC5 in Ubuntu
« Reply #5 on: August 31, 2011, 09:33:13 am »
In Synaptic I show 30,621 packages listed, 1485 installed, 0 broken, 0 to install/upgrade.  python 2.7 is not listed as an available package, could this be the issue?

Nope. Packages are located in different repositories, but a stock install of Ubuntu does not enable all the repositories. A stock install will list only a few thousand packages. That you have 30,621 packages available tells me that you have enabled all the repositories. Therefore, my suggestion was useless and something else is causing the problem. I don't know what it is and I have no further suggestions. Hopefully someone smarter than me will come along with more suggestions.
Linguistics on Linux!

brohan

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
Re: Help installing RC5 in Ubuntu
« Reply #6 on: August 31, 2011, 09:38:28 am »
For the hay of it, I manually downloaded and installed python 2.7.2 in the /usr/bin directory. As I am new to Linux, I am not sure that Linux recognizes that I have 2.7.2 installed, or if just 2.6 is available. Can one have more than one installed and recognized?  I went and tried to install Scribus RC5 again, but same issues. I shall wait for help.