Scribusoid

Author Topic: Footnotes all turn to zero (struggling) 1.5.0svn  (Read 1675 times)

Paul McG

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Footnotes all turn to zero (struggling) 1.5.0svn
« on: January 20, 2016, 04:34:04 pm »
So, today I moved on to the next stage, which is adding footnotes. All going well until - whooops! - all the footnotes are numbered 0 (see attached). The numbers in the text are OK, but the footnotes at the bottom are no good.

I found this link: http://bugs.scribus.net/view.php?id=11661

which looks like the same thing from last year. But is there a solution?

I tried reopening the same file on my MacBook, but have the same problem.

This is a bit of a deal breaker for me. Can anyone help?

Paul


a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2114
  • Karma: 27
    • the graphics lab
Re: Footnotes all turn to zero (struggling) 1.5.0svn
« Reply #1 on: January 20, 2016, 06:57:11 pm »
hey, the solution depends on the version your using

if you're using the released 1.5.0, stop using footnotes before it's too late :-(

if you're compiling yourself 1.5svn from the current code, well, the footnotes are still not a stable feature.

there has been some work been done after 1.5.0 has been released and there should be no document corruption anymore when using footnotes... but the new code has not been tested.
so, if you're using the latest code, you're ready to write bug reports, and you're brave enough: you're welcome to play the guinea pig... otherwise i would also suggest you not to use the footnotes yet...

have a nice evening

Paul McG

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
  • Scribus User
Re: Footnotes all turn to zero (struggling) 1.5.0svn
« Reply #2 on: January 20, 2016, 07:03:33 pm »
That is very disappointing. I have made so much progress in the last few days, but without footnotes Scribus can't do what I need. Thanks anyway. Paul

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2114
  • Karma: 27
    • the graphics lab
Re: Footnotes all turn to zero (struggling) 1.5.0svn
« Reply #3 on: January 20, 2016, 08:29:46 pm »
well, it depends a bit on how many footnotes you will have... if it's less than 20 you might create them "manually"...

if you have many... not a practical solution, of course!