Author Topic: OSX users who run 1.5.1 please test this bug  (Read 1423 times)

Kunda

  • Administrator
  • Full Member
  • *****
  • Posts: 218
  • Karma: 2
  • Scribus User
OSX users who run 1.5.1 please test this bug
« on: September 27, 2015, 12:39:46 am »
http://bugs.scribus.net/view.php?id=13187

It will require you logging-in/signing up to the bug tracker to give your results.

Thanks

GarryP

  • Hero Member
  • *****
  • Posts: 1600
  • Karma: 25
  • Scribus User
Re: OSX users who run 1.5.1 please test this bug
« Reply #1 on: September 28, 2015, 03:21:37 pm »
Done, and note added (couldn't replicate problem).

Kunda

  • Administrator
  • Full Member
  • *****
  • Posts: 218
  • Karma: 2
  • Scribus User
Re: OSX users who run 1.5.1 please test this bug
« Reply #2 on: September 29, 2015, 01:46:56 am »
thanks Garry!
I updated the bug to reflect a better way to reproduce.
But no need to try to reproduce since we may have found the issue.

Cheers!

BTW... can you update your build since there have been over 100 commits since you did?
brew update && brew upgrade --all && brew reinstall --HEAD scribus --verbose

GarryP

  • Hero Member
  • *****
  • Posts: 1600
  • Karma: 25
  • Scribus User
Re: OSX users who run 1.5.1 please test this bug
« Reply #3 on: September 29, 2015, 12:00:36 pm »
No problem Kunda. Glad to hear the problem has been found.

On a Homebrew note, I tried "brew update" and got the following message:
Code: [Select]
Agreeing to the Xcode/iOS license requires admin privileges, please re-run as root via sudo.
Would this be expected? I thought Homebrew didn't need root access. (I recently upgraded my XCode installation.)

Kunda

  • Administrator
  • Full Member
  • *****
  • Posts: 218
  • Karma: 2
  • Scribus User
Re: OSX users who run 1.5.1 please test this bug
« Reply #4 on: September 29, 2015, 02:49:35 pm »
Hey GarryP,

You're right it doesn't need root access. It's for updating Xcode.
Check out the solution over at stackoverflow and follow it exactly: http://stackoverflow.com/questions/27499434/troubles-with-installation-of-homebrew

Cheers

GarryP

  • Hero Member
  • *****
  • Posts: 1600
  • Karma: 25
  • Scribus User
Re: OSX users who run 1.5.1 please test this bug
« Reply #5 on: September 29, 2015, 03:20:05 pm »
Thanks Kunda, that did the trick.

As clarification to anyone else reading this, all you have to do is:
(1) Run XCode.
(2) Accept the licence agreement.
(3) Enter your password (if necessary) to allow XCode to finish installing its components.
(4) Close XCode.

And you should be up-and-running again.