Author Topic: Hyphenation does not work (anymore)  (Read 4896 times)

knoppi

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Hyphenation does not work (anymore)
« on: November 25, 2014, 01:48:14 pm »
Hi!

I just noted that hyphenation in Scribus 1.4.4 from the Ubuntu 14.10 repositories doesn't work (clicking on Menu->Extras->Perform hyphenation simply does nothing in situations where it used to do something). In the version shipped with Ubuntu 14.04 it works.
Interestingly, the hyphenation performed in the older version can be reverted in the newer version.  ::)

Is this problem only appearing for me or is anyone else also affected?

knoppi

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Hyphenation does not work (anymore)
« Reply #1 on: November 25, 2014, 10:45:19 pm »
Ok, interesting.
I have an _old_ version: the one which comes with Ubuntu 14.04, labelled 1.4.2. Funnily, while the source folder is called 1.4.2, the window title, when I open the program tells me 1.4.3svn...
I have a _new_ version: comes with Ubuntu 14.10, labelled 1.4.4

Now, I downloaded the Ubuntu source packages for both version and just did quick check if I could compile them. I could. However, I noticed that the source package of the new version does not contain dictionary files as they are published under LGPL and, hence, are removed during the "debianization".
Eventually, both version did not do the hyphenation. They even didn't allow me to choose a language for hyphenation rules. So, probably something went wrong, eh?

What I did, was quite stupid straighforward without digging much into how the code of Scribus is organized. This is why I'm not sure if my installation is simply missing some dependency or if it is really a problem of Scribus (I saw that some OverrideCursor methods were changed from 1.4.3 to 1.4.4) or of the Ubuntu packaging. If you have some hint for me I can look again.

knoppi

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Hyphenation does not work (anymore)
« Reply #2 on: November 27, 2014, 12:13:20 am »
Hi!

No hint? Can I conclude that you all don't have this problem? Are you all using other distros or Windows version of Scribus?
If somebody else uses ubuntu 14.10 and doesn't have this problem I would be glad to know, as this would restrict the search for an error to my particular installation.

GarryP

  • Hero Member
  • *****
  • Posts: 1600
  • Karma: 25
  • Scribus User
Re: Hyphenation does not work (anymore)
« Reply #3 on: November 27, 2014, 02:42:24 pm »
Hi knoppie.

As there are only a few dozen regularly active users of the forum there aren't a lot of people who can answer every problem. (E.g. The current average logins per day is only around 22 people.) And problems that are specific to a certain version of one of the many available OSes are much less likely to get an answer as the number of people actually able to give an answer - due to specific technical knowledge, etc. - reduces significantly.

Usually someone can offer some kind of a suggestion but you sometimes have to wait a while. For example, some people may only look into the forum on a weekly basis because of other responsibilities or internet access issues, etc.

It's a shame that you haven't been able to get an answer yet but it's only been a couple of days. I realise it's probably very frustrating for you as you just want to get on with things, but if no-one that has seen your question can answer it then no-one will answer it. The general disposition of this forum - as I've observed - is to "give real answers when you know them and don't just give opinions". Thus people tend to keep quiet unless they're pretty sure they can actually help you rather than give vague ideas in the hope that something they say might help in some way. (This isn't always true but it seems to be a general rule of thumb.)

So, just hang on in there and hopefully someone might come to your rescue. But, as no-one is getting paid for this, you shouldn't expect to get an answer just because you've asked a question. Sometimes, no-one knows.

I hope you stick with the forum anyway, even if you can't get an answer to this problem here.

knoppi

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Hyphenation does not work (anymore)
« Reply #4 on: November 27, 2014, 10:28:32 pm »
Sorry for seeming impatient. I'm quite familiar to the ways open source software and community help works. And I don't expect help as if I had a right for it.

My main intention was to add information to my original post to point out I'm not sitting there and waiting four you to help me out.

placidoaps

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
  • Scribus User
Re: Hyphenation does not work (anymore)
« Reply #5 on: December 06, 2014, 06:04:39 pm »
Hi,

I use Ubuntu 14.10 with Gnome 3.
I solve this problem (in my case pt_PT) this way.

1. Installed scribus in Windows machine.
2. Copy all the content of the of the folder     c:\programs\scribus 1.4.4\share\dicts\     to a usb drive
3. Copy the files and folder that you copy in 2. to the folder     /usr/share/scribus/ditcs    need root privileges
4. Restart scribus.

Hope this helped!
« Last Edit: December 06, 2014, 06:07:04 pm by placidoaps »

knoppi

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Hyphenation does not work (anymore)
« Reply #6 on: December 08, 2014, 11:53:21 am »
Hi!

Thanks for the advice. It worked!  :-*

I have a similar way of solving this problem which might hint at the origin of the problem. Hyphenation files exist in two naming schemes: hyph_xx.dic or hyph_xx_YY.dic where xx is the language part and YY is the country part.
In placidoaps' case this is portuguese from Portugal. Ubuntu ships Scribus with two files: hyph_pt_PT.dic and hyph_pt_BR.dic. The Windows version comes with hyph_pt.dic and hyph_pt_BR.dic.
Maybe Scribus registers those all files but, eventually, only reads the ones without the country part. My alternative solution (for german hyphenation rules) is the following:
I have a hyph_de_DE.dic in my /usr/share/scribus/dicts folder and copied this to hyph_de.dic. Et voilà, same results as with copying from Windows. Note that you have to copy or hardlink the file, symlinks do not work.