Author Topic: Compiling Scribus - Qt include conflicts  (Read 1425 times)

Juha

  • Newbie
  • *
  • Posts: 7
  • Karma: 0
  • Scribus User
Compiling Scribus - Qt include conflicts
« on: November 05, 2014, 10:29:31 am »
I am compiling Scribus source codes on my Windows 7 64bit system. I have Visual Studio 2012 c++ compiler and Scribus source 1.4.4. I am insecure about QT version that I should use because of include contradictions. I have installed Qt 5.3 and Qt 4.8.6.

I started compiling using Scribus-1.4.x.sln solution found from

\Scribus\win32\vc11. I have loaded all needed libraries and edited Scribus-build-props.props file according my setup.

I used this page as my guide:
http://scribus.net/websvn/filedetails.php?repname=Scribus&path=%2Ftrunk%2FScribus%2FBUILDING_win32_msvc.txt

Now the qt includes in Scribus source are the problem. Most of Scribus Qt includes seems to be for Qt5 but some for Qt4.

1. This happens when compiling with qt 4.8.6

I get mass of errors like:

c:\c\lib2\scribus\scribus\ui_aligndistribute.h(13): fatal error C1083: Cannot open include file: 'QtWidgets/QAction': No such file or directory (..\..\..\scribus\canvasmode_legacy.cpp)

There is no QtWidgets directory in qt4. That is found in qt5.
 
2. This happens when compiling with qt 5.3

C:\c\lib2\Scribus\scribus\scribus.h(63): fatal error C1083: Cannot open include file: 'QWorkspace': No such file or directory

QWorkspace file is not found in qt5 but it is found in qt4. So this include assumes qt4 when most of other includes assume qt5.

See here my Qt include structure:

http://juhamartikainen.1g.fi/kuvat/test/qt_4_8_6.png

http://juhamartikainen.1g.fi/kuvat/test/qt_5_3.png