Scribusoid

Author Topic: Applying textstyles doesn't work like it used to  (Read 2845 times)

hjongste

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Applying textstyles doesn't work like it used to
« on: March 02, 2014, 07:13:29 am »
I recently moved from version 1.3.3.14 to version 1.4.3. In the text editor when I select all text with the mouse and apply a style it doesn't work. In the left column it shows correctly the style of each paragraph, but upon saving the changes only the first paragraph is formatted using the new style. I have to click on each paragraph and seprately change its style for it to work which is very cumbersome. Is this a known issue?

utnik

  • Hero Member
  • *****
  • Posts: 1319
  • Karma: 14
Re: Applying textstyles doesn't work like it used to
« Reply #1 on: March 02, 2014, 09:55:16 am »
hi hjongste

within the story editor you have two different ways to choose a paragraph style:
  • the one on the left changes the settings of its own paragraph
  • the one at the toolbar works for your selection
utnik

hjongste

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Applying textstyles doesn't work like it used to
« Reply #2 on: March 02, 2014, 10:06:49 am »
Hi utnik,

Thanks for reply. yes the first one works but is tedious as you have to do it for each separate paragraph. It is exactly the second one that doesn't work for me. I have selected the entire text (multiple paragraphs), then on the tool bar I select the style and change it. In the left column it shows the selected new style, but in the text (after saving of course) it has only changes the style for the first paragraph. It drives me nuts!

utnik

  • Hero Member
  • *****
  • Posts: 1319
  • Karma: 14
Re: Applying textstyles doesn't work like it used to
« Reply #3 on: March 02, 2014, 11:53:54 am »
hi hjongste

sounds really strange to me.
i just tried it with scribus 1.4.3 on macOS and winXP and with 1.4.3svn on ubuntu – for me it works on all this platforms as expected…

i think, there must be some problem with your installation.

utnik

hjongste

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Applying textstyles doesn't work like it used to
« Reply #4 on: March 03, 2014, 07:06:00 am »
It see this problem has been reported before (http://forums.scribus.net/index.php/topic,732.msg3411.html#msg3411) and the comment is that the text editor "... is due for rewriting and the recommendation today is to try to avoid it".

I'll look a bit more into it and see if the recommendation (double click and edit |in place") works. Great if it still works for you.

Dave Barber

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: Applying textstyles doesn't work like it used to
« Reply #5 on: February 10, 2016, 07:42:16 pm »
Yes I have discovered the same problem which appears to have started with latest version. One of the really annoying traits is when I resize type from e.g. 12pt upwards, it will only increase in 1pt increments

CGood

  • Full Member
  • ***
  • Posts: 109
  • Karma: 0
  • Scribus User
Re: Applying textstyles doesn't work like it used to
« Reply #6 on: September 05, 2016, 05:58:45 am »
.... One of the really annoying traits is when I resize type from e.g. 12pt upwards, it will only increase in 1pt increments

I know I am revisiting an old post, but there is a way to change font size faster, at least in 1.4.x and 1.5.1 - select or even just click within the font size box, then hit page up or page down to get 10 pt increments in size.

 

palmate