Scribusoid

Author Topic: bad text quality in my document .sla  (Read 6464 times)

Ma.

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
  • Scribus User
bad text quality in my document .sla
« on: January 20, 2014, 05:48:18 pm »
Hi,

First, sorry for my English.
Here's my problem : when I export my Scribus document in pdf and then print it, quality of text is bad (as if it were bold and fuzzy). When I open a new scribus document and add text, it's the same problem.
However, I opened .sla from a post of this forum, I added text on it, export in pdf and print it, and the result is in very good quality.
I used the same police, size, and other text properties in these two documents. I also compared general properties and there are the same for both documents. I do not understand what's wrong in my document.
Do you have any idea?
Thanks for your help!

utnik

  • Hero Member
  • *****
  • Posts: 1188
  • Karma: 14
Re: bad text quality in my document .sla
« Reply #1 on: January 20, 2014, 07:49:46 pm »
could you provide an .sla file for testing? (include the used fonts via 'file' → 'collect for output')

utnik

Ma.

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
  • Scribus User
Re: bad text quality in my document .sla
« Reply #2 on: January 21, 2014, 10:31:57 am »
Thank you utnik for you interest in my problem.
Here's a document.
Ma.

utnik

  • Hero Member
  • *****
  • Posts: 1188
  • Karma: 14
Re: bad text quality in my document .sla
« Reply #3 on: January 21, 2014, 08:38:52 pm »
hi ma.

i just took a look at your file.
under: 'file' → 'document setup' → 'fonts' you'll find the reason for the bad text output.

'arial regular' (the font in your text box) is marked to be used, but the box 'embed in postscript' is unchecked – try to export the .pdf file with this box checked!

utnik

Ma.

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
  • Scribus User
Re: bad text quality in my document .sla
« Reply #4 on: January 22, 2014, 10:53:11 am »
Hi utnik,

Thank you again for you help!
When I open the document in my pc with Scribus 1.4.3, all fonts are marked to be used and all box "embed in postscript" are checked. I tried to uncheck and check again, but nothing change for printing...
If you want to see the scanned pdf export (exbad) compared to document download in this forum (exgood).

Thanks,
Ma.

utnik

  • Hero Member
  • *****
  • Posts: 1188
  • Karma: 14
Re: bad text quality in my document .sla
« Reply #5 on: January 22, 2014, 11:52:24 am »
why scanned printer outputs, when you have the original .pdf files as well?
what i can see on the two bitmap images are scanning and threshold artefacts…

utnik

Ma.

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
  • Scribus User
Re: bad text quality in my document .sla
« Reply #6 on: January 22, 2014, 12:07:47 pm »
It was just to show you. In pdf, the difference in quality is not as obvious.

utnik

  • Hero Member
  • *****
  • Posts: 1188
  • Karma: 14
Re: bad text quality in my document .sla
« Reply #7 on: January 22, 2014, 12:26:07 pm »
In pdf, the difference in quality is not as obvious.

  • does the visual difference change, when you display the .pdf file in small zoom levels?
  • are the fonts embedded in both files? ('file' → 'document properties' → 'fonts' in adobe reader)
utnik

Ma.

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
  • Scribus User
Re: bad text quality in my document .sla
« Reply #8 on: January 22, 2014, 12:49:53 pm »
In small zoom, quality of .pdf if very good.

Indeed, there is problem in "fonts properties" in adobe reader :
It indicate "real fonts : Fo0S0" and "Type : Type 3"
while in "good" .pdf : "real fonts : ArialMT" and "Type : TrueType"

Have you an idea How can we change it (in scribus I think)?

Thanks a lot!

Ma.
« Last Edit: January 22, 2014, 12:55:55 pm by Ma. »

utnik

  • Hero Member
  • *****
  • Posts: 1188
  • Karma: 14
Re: bad text quality in my document .sla
« Reply #9 on: January 22, 2014, 02:39:46 pm »
…"real fonts : Fo0S0" and "Type : Type 3"…

…Have you an idea How can we change it (in scribus I think)?

this 'Fo…' stuff (so called 'type3') is what scribus creates with fonts listed in the 'fonts to outline' box. to avoid this, the fonts should be in the 'fonts to embed' box. (which only works, if 'embed in postscript' is selected in the document properties…)

utnik

Ma.

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
  • Scribus User
Re: bad text quality in my document .sla
« Reply #10 on: January 22, 2014, 03:22:27 pm »
Yes it works!!!!
But (I'm sorry there is a 'but') it doesn't works for all fonts, especially Calibri font. When I look "fonts properties" in adobe reader, nothing appear.
Is it possible that this font does not exist in adobe reader ?

utnik

  • Hero Member
  • *****
  • Posts: 1188
  • Karma: 14
Re: bad text quality in my document .sla
« Reply #11 on: January 22, 2014, 05:19:39 pm »
…it doesn't works for … Calibri font.

i don't use the microsoft fonts. calibri might be protected against embedding…

Quote
Is it possible that this font does not exist in adobe reader ?

there aren't any fonts in adobe reader. the reader takes the fonts from the .pdf files (or from the font directory of the operating system…)

utnik

edit: just took a look at calibri with 'fontforge' – it's marked as embeddable for 'editable documents' only. when i change this to 'printable document', calibri appeares in the adobe reader as embedded true type font.
but as this is not the legal way, i won't provide the changed font file here…
« Last Edit: January 22, 2014, 05:44:15 pm by utnik »

Ma.

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
  • Scribus User
Re: bad text quality in my document .sla
« Reply #12 on: January 22, 2014, 06:26:36 pm »
Thank you very much utnik for your help and all these explanations!

Quote
just took a look at calibri with 'fontforge' – it's marked as embeddable for 'editable documents' only

Ok I understand and I will used Arial font. So it's the same problem for all DTP? And why it is embeddable from Word (in 'subset')?

Thanks again!
Ma.

utnik

  • Hero Member
  • *****
  • Posts: 1188
  • Karma: 14
Re: bad text quality in my document .sla
« Reply #13 on: January 22, 2014, 08:19:28 pm »
why it is embeddable from Word (in 'subset')?

because .doc and .docx are recignized as editable documents – i supose.
but as i don't like the licensing policy of microsoft and neither use their fonts nor their office suite, i won't go any deeper into this…

utnik

Ma.

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
  • Scribus User
Re: bad text quality in my document .sla
« Reply #14 on: January 23, 2014, 11:08:50 am »
Ok, thanks again for your help utnik!

Ma.

 

palmate