Scribusoid

Author Topic: Hyperlink works in Evince, but not in Acrobat Reader  (Read 4534 times)

owlbrudder

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Hyperlink works in Evince, but not in Acrobat Reader
« on: December 28, 2013, 09:52:45 am »
I am just learning the ropes with Scribus and PDFs, so please forgive me if I am doing something stupid.

I am running Fedora 19 Linux.

To test how to cretae hyperlinks, I have created a document consisting of two text boxes. For one, I have created an external hyperlink to www.google.com. For the other, I have created an external hyperlink to a dummy mailto: address. I have exported the document as a PDF.

When I open the PDF in Evince, the hyperlink to the web address works as I expect, but the mailto: opens a browser tab in an existing instance of Firefox, as well as initiating an Evolution email to the correct address - is this normal? It is only a minor issue, but may indicate I am doing something incorrectly.

More worryingly, when I open this PDF (or any PDF containing hyperlinks) in Acrobat Reader (I am running version 9.5.5), web address hyperlinks do not work at all, even though the mouse pointer changes to a pointing hand, but mailto: hyperlinks open a new browser instance with a 'New Tab' tab and a tab for the mailto: address, then three blank Evolution emails are created, all initialised to the email address specified in the link. None of this behaviour is what I expected.

To test this, have a look at this PDF: www.csiro.au/files/files/plje.pdf‎ On the second page, near the bottom, is an instance of a web address and of a mailto: address. These work as described above for Acrobat Reader, but neither link is recognised at all by Evince (the mouse pointer does not even change as I pass over them), indicating to me that there is a difference in the way they have been created, perhaps?

This is important to me, as I plan to create a club newsletter that will be distributed by email and will contain hyperlinks, so I need to know it will work for all users regardless of platform: most will be running Windows, I expect.

All suggestions will be gratefully received.

Oh, and Happy New Year ...

Kunda

  • Administrator
  • Full Member
  • *****
  • Posts: 218
  • Karma: 2
  • Scribus User
Re: Hyperlink works in Evince, but not in Acrobat Reader
« Reply #1 on: December 29, 2013, 10:08:20 pm »
FYI, The http://www.csiro.au/files/files/plje.pdf link actually is encoded like this in your message:
http://www.csiro.au/files/files/plje.pdf%E2%80%8E
So it returns a 404.

owlbrudder

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Hyperlink works in Evince, but not in Acrobat Reader
« Reply #2 on: December 31, 2013, 09:51:10 am »
Thanks, Kunda - I did not notice that at the time. Ooops!

GarryP

  • Hero Member
  • *****
  • Posts: 1600
  • Karma: 25
  • Scribus User
Re: Hyperlink works in Evince, but not in Acrobat Reader
« Reply #3 on: December 31, 2013, 02:45:05 pm »
It’s worth noting that most PDF readers - including Acrobat - will automatically create hyperlinks from text that looks like a URL. (It’s similar to what this forum does.)

So, for instance, if you have www.google.co.uk in the text, the PDF reader will most likely make a link to it “on the fly” and you don’t need to do anything within Scribus to enable that to happen. (This should include “mailto:” links too but I haven’t checked all readers.)

However, if you want to create a link from a button or graphic or a word or phrase that doesn’t have the exact wording of the URL that you want then you’ll need to create the link yourself - as it sounds like you have already been doing. This isn’t ideal as formatting/text changes mean you might have to move the links around manually.

Sometimes it can look better if the URL is shown in the text - unless it’s particularly verbose - as people sometimes just want to just note down or copy and paste the link for use somewhere else. It depends on how technically-minded your audience is. Also, some people are wary of clicking on something if they don’t know where they’re going to end up.

All in all, I’d recommend putting the full URL into the text and letting the PDF reader sort things out, unless that’s impractical or makes things look messy. But that’s a personal thing and doesn’t take individual aesthetic needs into consideration.

P.S. Most PDF readers won’t automatically highlight a URL (apart from changing the pointer when you mouse over it) so you might want to create a Character Style - underlined and blue, or whatever - to apply to the relevant bits of text so people can see them more easily.
« Last Edit: December 31, 2013, 02:55:17 pm by GarryP »

owlbrudder

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: Hyperlink works in Evince, but not in Acrobat Reader
« Reply #4 on: January 07, 2014, 08:55:06 am »
Thanks very much, GarryP. All you wrote makes sense. I appreciate your taking the time to explain it.

GarryP

  • Hero Member
  • *****
  • Posts: 1600
  • Karma: 25
  • Scribus User
Re: Hyperlink works in Evince, but not in Acrobat Reader
« Reply #5 on: January 07, 2014, 02:09:38 pm »
You're welcome. I hope what I've said is of some use.

And just one more point, if you have got a long URL that doesn't look nice on the page you could always try one of the URL shortening services like bit.ly to create a nicer one. (I'm not sure how they cope with deep linking etc. but they may be worth a look.)

 

palmate