Scribusoid

Author Topic: Problems with font embedding on a text box  (Read 2949 times)

SteveBallantyne

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Problems with font embedding on a text box
« on: March 01, 2011, 09:44:09 pm »
Hello all,

I have a problem that seems to present itself on a clean installation of Scribus 1.4.0 running on Windows 7.

When I create a text field box, and then export that form to a PDF (ensuring to embed all fonts) my text boxes simply "don't work" on the form.  That is, I cannot enter text in them.

If I right-click the text box and "Edit Text", the chosen font is always some obscure font that happens to be at the very top of the list alphabetically.  If I click the drop down and try to use Arial Regular (which is the font I have chosen to use as a default) - it's not on the list.  It IS on the list for a Text Frame, but not a Text Field.

I have had this problem on a couple of different workstations and I am not sure what the problem is. 

Can anyone give me some ideas on why this is happening?

Thanks,
-Steve Ballantyne

SteveBallantyne

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Re: Problems with font embedding on a text box
« Reply #1 on: March 03, 2011, 04:42:35 pm »
I found a work-around to this problem, albeit a really bad work-around.

I got into File > Preferences > Fonts, and then unchecked EVERYTHING except for one working font (such as Verdana and it's variants).

Now Scribus does not keep switching to a strange font from the top of the list, because the top of the list (and the only thing on the list) is Verdana.  Then when I export to a PDF, there is only one font to embed, Verdana, and it works without issue.

Still ... I would love to know the source of this issue.  I don't believe I had these problems with the 1.3.x branch?

Thanks,
-Steve Ballantyne

cezaryece

  • Newbie
  • *
  • Posts: 17
  • Karma: 0
Re: Problems with font embedding on a text box
« Reply #2 on: March 07, 2011, 10:27:54 am »
Meybe you should write a bug report in bugs.scribus.net
Jabber: cezaryece@oferuje.pl

SteveBallantyne

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Re: Problems with font embedding on a text box
« Reply #3 on: March 07, 2011, 03:48:21 pm »
Good call.  I have opened a bug report for this one:

http://bugs.scribus.net/view.php?id=9806

 

palmate